summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-07 00:30:41 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-09 01:02:50 +0200
commit8c3dc6ee17ae424a16d8f44847a3a3aa8918f408 (patch)
treeb465dd19becd3362b85b8498ddf50349f4599ff5 /net-misc/networkmanager-openvpn/files
parentmozconfig-v6.48.eclass: Ensure --host is always set, bug 590498 (diff)
downloadgentoo-8c3dc6ee17ae424a16d8f44847a3a3aa8918f408.tar.gz
gentoo-8c3dc6ee17ae424a16d8f44847a3a3aa8918f408.tar.bz2
gentoo-8c3dc6ee17ae424a16d8f44847a3a3aa8918f408.zip
net-misc/networkmanager-openvpn: version bump to 1.2.2 to 1.2.4
dbus-glib is not needed anymore. Fixes bug #588388 as well. Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/networkmanager-openvpn/files')
-rw-r--r--net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-1.patch46
-rw-r--r--net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-2.patch58
2 files changed, 104 insertions, 0 deletions
diff --git a/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-1.patch b/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-1.patch
new file mode 100644
index 000000000000..3b6d4a68fd8d
--- /dev/null
+++ b/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-1.patch
@@ -0,0 +1,46 @@
+From 220b38717f8d0fc16c8b9d68cfd6e5b5751e4669 Mon Sep 17 00:00:00 2001
+From: Dennis Schridde <devurandom@gmx.net>
+Date: Mon, 15 Aug 2016 16:36:57 +0200
+Subject: build: fix linking libnm-vpn-plugin-openvpn.la for dlopen()
+
+On some systems, dlopen() is not in libdl.so [1].
+
+[1] https://autotools.io/autoconf/finding.html
+
+https://bugzilla.gnome.org/show_bug.cgi?id=769783
+---
+ configure.ac | 3 +++
+ properties/Makefile.am | 3 ++-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 34829f4..3988bad 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,6 +38,9 @@ dnl
+ AC_PROG_GCC_TRADITIONAL
+ AC_FUNC_MEMCMP
+ AC_CHECK_FUNCS(select socket uname)
++AC_SEARCH_LIBS([dlopen], [dl dld], [], [
++ AC_MSG_ERROR([unable to find the dlopen() function])
++])
+
+ dnl ensure that when the Automake generated makefile calls aclocal,
+ dnl it honours the $ACLOCAL_FLAGS environment variable
+diff --git a/properties/Makefile.am b/properties/Makefile.am
+index 552e537..04ed5cd 100644
+--- a/properties/Makefile.am
++++ b/properties/Makefile.am
+@@ -57,7 +57,8 @@ libnm_vpn_plugin_openvpn_la_CFLAGS = \
+ $(LIBNM_CFLAGS)
+
+ libnm_vpn_plugin_openvpn_la_LIBADD = \
+- $(LIBNM_LIBS)
++ $(LIBNM_LIBS) \
++ $(DLOPEN)
+
+ libnm_vpn_plugin_openvpn_la_LDFLAGS = \
+ -avoid-version \
+--
+cgit v0.12
+
diff --git a/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-2.patch b/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-2.patch
new file mode 100644
index 000000000000..deddddcf5d29
--- /dev/null
+++ b/net-misc/networkmanager-openvpn/files/networkmanager-openvpn-1.2.4-underlinking-2.patch
@@ -0,0 +1,58 @@
+From 8d76aebe99b1b9c67adab4922c0c33edb1f89b7f Mon Sep 17 00:00:00 2001
+From: Thomas Haller <thaller@redhat.com>
+Date: Mon, 15 Aug 2016 16:55:01 +0200
+Subject: build: use $(DL_LIBS) name for -ldl
+
+Usually, our variables for libraries are call *_LIBS. Adjust the name.
+---
+ configure.ac | 6 +++---
+ properties/Makefile.am | 3 ++-
+ properties/tests/Makefile.am | 1 -
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3988bad..142fa67 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,9 +38,9 @@ dnl
+ AC_PROG_GCC_TRADITIONAL
+ AC_FUNC_MEMCMP
+ AC_CHECK_FUNCS(select socket uname)
+-AC_SEARCH_LIBS([dlopen], [dl dld], [], [
+- AC_MSG_ERROR([unable to find the dlopen() function])
+-])
++
++AC_SEARCH_LIBS([dlopen], [dl dld], [], [ac_cv_search_dlopen=])
++AC_SUBST([DL_LIBS], "$ac_cv_search_dlopen")
+
+ dnl ensure that when the Automake generated makefile calls aclocal,
+ dnl it honours the $ACLOCAL_FLAGS environment variable
+diff --git a/properties/Makefile.am b/properties/Makefile.am
+index 04ed5cd..12ee00c 100644
+--- a/properties/Makefile.am
++++ b/properties/Makefile.am
+@@ -58,7 +58,8 @@ libnm_vpn_plugin_openvpn_la_CFLAGS = \
+
+ libnm_vpn_plugin_openvpn_la_LIBADD = \
+ $(LIBNM_LIBS) \
+- $(DLOPEN)
++ $(DL_LIBS) \
++ $(NULL)
+
+ libnm_vpn_plugin_openvpn_la_LDFLAGS = \
+ -avoid-version \
+diff --git a/properties/tests/Makefile.am b/properties/tests/Makefile.am
+index c4639ee..c3eef5b 100644
+--- a/properties/tests/Makefile.am
++++ b/properties/tests/Makefile.am
+@@ -27,7 +27,6 @@ test_import_export_LDADD = \
+ $(GTK_LIBS) \
+ $(LIBNM_LIBS) \
+ $(LIBNMA_LIBS) \
+- -ldl \
+ $(top_builddir)/properties/libnm-vpn-plugin-openvpn-test.la
+
+
+--
+cgit v0.12
+