summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-01-30 20:16:45 -0500
committerCraig Andrews <candrews@gentoo.org>2022-01-30 20:17:04 -0500
commit9d0ada5ce329c7d5e801ce3682887acfcd2e509e (patch)
treeeb1c01525e7faa8cebd47ca39b41f17ef9561d2f /net-misc/mptcpd
parentdev-ml/core_kernel: <dev-ml/jst-config-0.15.0; add ppx_optcom dep (diff)
downloadgentoo-9d0ada5ce329c7d5e801ce3682887acfcd2e509e.tar.gz
gentoo-9d0ada5ce329c7d5e801ce3682887acfcd2e509e.tar.bz2
gentoo-9d0ada5ce329c7d5e801ce3682887acfcd2e509e.zip
net-misc/mptcpd: multipath TCP path management
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/mptcpd')
-rw-r--r--net-misc/mptcpd/Manifest1
-rw-r--r--net-misc/mptcpd/metadata.xml11
-rw-r--r--net-misc/mptcpd/mptcpd-0.9.ebuild61
-rw-r--r--net-misc/mptcpd/mptcpd-9999.ebuild61
4 files changed, 134 insertions, 0 deletions
diff --git a/net-misc/mptcpd/Manifest b/net-misc/mptcpd/Manifest
new file mode 100644
index 000000000000..bc4e09614710
--- /dev/null
+++ b/net-misc/mptcpd/Manifest
@@ -0,0 +1 @@
+DIST mptcpd-0.9.tar.gz 654063 BLAKE2B fd9e8bf5cec517c934b9d38a736a128d087b54b5e4db90816a8cf8c242195fec8e3c4cd28d2f6e5a93326cac311a6b29048313c722004cea39e19448dc467976 SHA512 4fd292304d6270351b865e86cc401c1f5cc9043606b171e852bd37b2472c5f80061d760be68e5cd965caccb2f25c03d9ceea6232a5a587016c81f85e68ca8882
diff --git a/net-misc/mptcpd/metadata.xml b/net-misc/mptcpd/metadata.xml
new file mode 100644
index 000000000000..ed0b180f23fb
--- /dev/null
+++ b/net-misc/mptcpd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/mptcpd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/mptcpd/mptcpd-0.9.ebuild b/net-misc/mptcpd/mptcpd-0.9.ebuild
new file mode 100644
index 000000000000..f337f9489235
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.30.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ app-doc/doxygen
+ app-text/pandoc
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}
diff --git a/net-misc/mptcpd/mptcpd-9999.ebuild b/net-misc/mptcpd/mptcpd-9999.ebuild
new file mode 100644
index 000000000000..f337f9489235
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.30.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ app-doc/doxygen
+ app-text/pandoc
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}