summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-03 11:30:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-03 11:47:30 +0200
commit9c0d4d7176d520fc1ebcf8ebc486b0f5d92b4d89 (patch)
treecfd7206529f4cd24af1dfb9ff07591b60989d184 /net-misc/icecast
parentnet-dns/pdnsd: Fixed openrc init script shebang. (diff)
downloadgentoo-9c0d4d7176d520fc1ebcf8ebc486b0f5d92b4d89.tar.gz
gentoo-9c0d4d7176d520fc1ebcf8ebc486b0f5d92b4d89.tar.bz2
gentoo-9c0d4d7176d520fc1ebcf8ebc486b0f5d92b4d89.zip
net-misc/icecast: Fixed openrc init script shebang.
Converted ebuild to EAPI-6. Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/files/icecast.initd (renamed from net-misc/icecast/files/init.d.icecast-2)4
-rw-r--r--net-misc/icecast/icecast-2.4.2.ebuild2
-rw-r--r--net-misc/icecast/icecast-2.4.3.ebuild22
3 files changed, 17 insertions, 11 deletions
diff --git a/net-misc/icecast/files/init.d.icecast-2 b/net-misc/icecast/files/icecast.initd
index bde5877c62b6..cb658a3907d4 100644
--- a/net-misc/icecast/files/init.d.icecast-2
+++ b/net-misc/icecast/files/icecast.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
extra_started_commands="reload"
diff --git a/net-misc/icecast/icecast-2.4.2.ebuild b/net-misc/icecast/icecast-2.4.2.ebuild
index 31271f707df7..225f05f930dd 100644
--- a/net-misc/icecast/icecast-2.4.2.ebuild
+++ b/net-misc/icecast/icecast-2.4.2.ebuild
@@ -58,7 +58,7 @@ src_install() {
dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
dohtml -A chm,hhc,hhp doc/*
- newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
insinto /etc/icecast2
diff --git a/net-misc/icecast/icecast-2.4.3.ebuild b/net-misc/icecast/icecast-2.4.3.ebuild
index caecb9b2443e..e14dda3eb908 100644
--- a/net-misc/icecast/icecast-2.4.3.ebuild
+++ b/net-misc/icecast/icecast-2.4.3.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils autotools systemd user
+EAPI=6
+inherit autotools systemd user
DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
HOMEPAGE="http://www.icecast.org/"
@@ -32,11 +32,16 @@ pkg_setup() {
enewuser icecast -1 -1 -1 nogroup
}
-src_prepare() {
+PATCHES=(
# bug #368539
- epatch "${FILESDIR}"/${PN}-2.3.3-libkate.patch
+ "${FILESDIR}"/${PN}-2.3.3-libkate.patch
# bug #430434
- epatch "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+ "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -56,9 +61,10 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
- dohtml -A chm,hhc,hhp doc/*
+ docinto html
+ dodoc doc/*.html
- newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
insinto /etc/icecast2
@@ -74,7 +80,7 @@ src_install() {
diropts -m0764 -o icecast -g nogroup
dodir /var/log/icecast
keepdir /var/log/icecast
- rm -rf "${D}"/usr/share/doc/icecast
+ rm -r "${D}"/usr/share/doc/icecast || die
}
pkg_postinst() {