summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-05 12:25:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-05 12:25:24 +0200
commit63f5f9a2207c30b2222e91e2db7c014479de9dce (patch)
treeec618c822ddd2d0e9b8f1d43d4e634b1537a4206 /net-misc/dhcpcd
parentx11-terms/terminator: update use-flag description (diff)
downloadgentoo-63f5f9a2207c30b2222e91e2db7c014479de9dce.tar.gz
gentoo-63f5f9a2207c30b2222e91e2db7c014479de9dce.tar.bz2
gentoo-63f5f9a2207c30b2222e91e2db7c014479de9dce.zip
net-misc/dhcpcd: Revbump to fix installation of embedded config
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9.1.1-r1.ebuild (renamed from net-misc/dhcpcd/dhcpcd-9.1.1.ebuild)2
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-9.1.1-embedded_config.patch43
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-9.1.1-typo_fix.patch11
3 files changed, 44 insertions, 12 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9.1.1.ebuild b/net-misc/dhcpcd/dhcpcd-9.1.1-r1.ebuild
index c4339429d808..0942b0cd0435 100644
--- a/net-misc/dhcpcd/dhcpcd-9.1.1.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9.1.1-r1.ebuild
@@ -34,7 +34,7 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}/${P}-typo_fix.patch"
+ "${FILESDIR}/${P}-embedded_config.patch"
)
src_configure() {
diff --git a/net-misc/dhcpcd/files/dhcpcd-9.1.1-embedded_config.patch b/net-misc/dhcpcd/files/dhcpcd-9.1.1-embedded_config.patch
new file mode 100644
index 000000000000..10e8520116f5
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-9.1.1-embedded_config.patch
@@ -0,0 +1,43 @@
+From fa1cd0004e0d3267a1217ada46e53df38824da2d Mon Sep 17 00:00:00 2001
+From: Roy Marples <roy@marples.name>
+Date: Thu, 4 Jun 2020 21:49:37 +0100
+Subject: Fix installing the embedded config as a file.
+
+---
+ src/if-options.c | 4 ++--
+ src/privsep-root.c | 4 ++++
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/if-options.c b/src/if-options.c
+index 212e71d8..3dde04bf 100644
+--- a/src/if-options.c
++++ b/src/if-options.c
+@@ -2366,8 +2366,8 @@ read_config(struct dhcpcd_ctx *ctx,
+ return ifo;
+ }
+ if (buf[buflen - 1] != '\0') {
+- if (buflen < sizeof(buf) - 1)
+- bulen++;
++ if ((size_t)buflen < sizeof(buf) - 1)
++ buflen++;
+ buf[buflen - 1] = '\0';
+ }
+ #else
+diff --git a/src/privsep-root.c b/src/privsep-root.c
+index fdf43856..512dfcc0 100644
+--- a/src/privsep-root.c
++++ b/src/privsep-root.c
+@@ -297,6 +297,10 @@ ps_root_validpath(const struct dhcpcd_ctx *ctx, uint16_t cmd, const char *path)
+ return false;
+
+ if (cmd == PS_READFILE) {
++#ifdef EMBEDDED_CONFIG
++ if (strcmp(ctx->cffile, EMBEDDED_CONFIG) == 0)
++ return true;
++#endif
+ if (strcmp(ctx->cffile, path) == 0)
+ return true;
+ }
+--
+cgit v1.2.3
+
diff --git a/net-misc/dhcpcd/files/dhcpcd-9.1.1-typo_fix.patch b/net-misc/dhcpcd/files/dhcpcd-9.1.1-typo_fix.patch
deleted file mode 100644
index 0d97b7f82756..000000000000
--- a/net-misc/dhcpcd/files/dhcpcd-9.1.1-typo_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcpcd-9.1.1/src/if-options.c
-+++ dhcpcd-9.1.1/src/if-options.c
-@@ -2367,7 +2367,7 @@
- }
- if (buf[buflen - 1] != '\0') {
- if (buflen < sizeof(buf) - 1)
-- bulen++;
-+ buflen++;
- buf[buflen - 1] = '\0';
- }
- #else