summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-09-15 12:01:40 +0200
committerJeroen Roovers <jer@gentoo.org>2017-09-15 12:01:40 +0200
commit9f078a84fa607ad81ae48874a46093dc06eba27a (patch)
treedc454ef73d53db119bd388667563c0f0ff79148f /net-misc/chrony
parentnet-print/cups-filters: update HOMEPAGE. (diff)
downloadgentoo-9f078a84fa607ad81ae48874a46093dc06eba27a.tar.gz
gentoo-9f078a84fa607ad81ae48874a46093dc06eba27a.tar.bz2
gentoo-9f078a84fa607ad81ae48874a46093dc06eba27a.zip
net-misc/chrony: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/Manifest1
-rw-r--r--net-misc/chrony/chrony-3.2.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index 382f361e3a3c..0b44b5218690 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -4,3 +4,4 @@ DIST chrony-2.4.1.tar.gz 390641 SHA256 0fd59e0ef625b4459e3a9c7f221c52f56596582bc
DIST chrony-3.1.tar.gz 424109 SHA256 9d9107dcdb7768a03dc129d33b2a7a25f1eea2f5620bc85eb00cfea07c1b6075 SHA512 4ba3a75c3634050bb63ba9ee80d9be7a295f44ce4d195a050e4be4738bd7dd807fe37f2289d7ead4a75272bd5ebadbd03c233c67f859e9b68871fca5a6671427 WHIRLPOOL d1b499bbcdd74a049c972c183d4b88365db4c6512d8011ca8b87f15c4e0d1bc882bde4f742591f5cfe49e820a5884f6b1960d132d5787be02a36bd57b9e2605f
DIST chrony-3.2-pre1.tar.gz 431211 SHA256 3c6fa2fe71ba670955498dcecab6a57c0b4ed8bc5a761629e96cd6038946942f SHA512 8ce54f246c3e11e72d90ba03e6f39894445eed314b26113c4a98b5746a00c1886291bf1bb20db68318c3310350b36ea6c88fe05607ae82e551ee93aea6e3fcb6 WHIRLPOOL 1fdf2b0d66b048b448e184b947416bd5ac10996633a41b77749f787ac88b2e605925174483ba8b52f398a1adc8c79b56a2c75d759d187066981dad8045c32eb2
DIST chrony-3.2-pre2.tar.gz 433579 SHA256 8fe90b486e33909c22362ad524701470cd119618013d10e6bc750edca0cb5fbd SHA512 ddc1008da21ee995bfc6049e713f79e9872a3c45d26867b763c41914000bcc5c016c968588d00f85547405bb0bc7950c5954b5757ef08edef8adf988c711546a WHIRLPOOL e4e52c1b5b08824acfae22f554aee464c6d642bd007f6a979fa89c931b7dfa848ec67798ab71c9e1e87cb9570521ad0278671af3ce420255a08b31b6574b1323
+DIST chrony-3.2.tar.gz 433882 SHA256 329f6718dd8c3ece3eee78be1f4821cbbeb62608e7d23f25da293cfa433c4116 SHA512 496af5bed91600f268c1a0fa577bb8c7785e485f78598b666829c674e94770c16548cec4289a2ae9d0a51191d2705eda00886cb6cccae3828aa201a49d4783a4 WHIRLPOOL b8a9045c81970653393c2afadece1e3a5e093c893b7ac3bae061bbd40bc043439e426df8da6598e36ef9589b4dd402419199307a9bfa48df526206952814667e
diff --git a/net-misc/chrony/chrony-3.2.ebuild b/net-misc/chrony/chrony-3.2.ebuild
new file mode 100644
index 000000000000..7df999b0de10
--- /dev/null
+++ b/net-misc/chrony/chrony-3.2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="https://chrony.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc seccomp selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="
+ ${CDEPEND}
+ html? ( dev-ruby/asciidoctor )
+ pps? ( net-misc/pps-tools )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c doc/*.man.in examples/* || die
+
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(use_enable seccomp scfilter) \
+ $(usex adns '' --disable-asyncdns) \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex rtc '' --disable-rtc) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --docdir=/usr/share/doc/${PF} \
+ --chronysockdir=/run/chrony \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --disable-sechash \
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs $(usex html '' 'ADOC=true')
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}