summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-02-04 20:28:03 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-02-04 20:28:15 +0100
commita70e79661f834a836a9476218427d6507172f6d6 (patch)
tree4ef3f5c57a335ed52bf866ccce83fcf9b4c29803 /net-mail
parentdev-python/gpep517: Fix tmp_path_retention_policy for tests (diff)
downloadgentoo-a70e79661f834a836a9476218427d6507172f6d6.tar.gz
gentoo-a70e79661f834a836a9476218427d6507172f6d6.tar.bz2
gentoo-a70e79661f834a836a9476218427d6507172f6d6.zip
net-mail/fetchmail: add 6.4.38
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.38.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 2d76b253b809..25c3e5d211d9 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1 +1,2 @@
DIST fetchmail-6.4.37.tar.xz 1202860 BLAKE2B 4dc7d116e9dc32c2ff070f669306d9f2c0f93d5638b748d7362d6c9ab8684ae7ed8e26278ecf63bf23e2fff27916f83f7287aff891bd90bad82793bb84775c40 SHA512 99a620380d9bd0713d76495f587adbcc95fc16e5fcb048dc528f3039ebd8fcfbb1e2f44e10fc25f70e50940ce89922ff39f1f3d724d1f47a8d4918a37c07d8d0
+DIST fetchmail-6.4.38.tar.xz 1220892 BLAKE2B 6bb743b0e1f47143f69e3790ba2ad8849d2ec216c5fd7cc427a737e00183f2e3a65007df9dc5ffdebd991bd13e079a501519b271d02b1fd75151032d74e84dd2 SHA512 f58ab1275ceab2d11df590d32f5f59a8eb656ddab13bc47ffee8962aed53ce0509aa2cc100d5d67e59dac76c2d8159655a702e0c3f454d218b070129f785be59
diff --git a/net-mail/fetchmail/fetchmail-6.4.38.ebuild b/net-mail/fetchmail/fetchmail-6.4.38.ebuild
new file mode 100644
index 000000000000..5090653a89cd
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.38.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="ssl nls kerberos tk selinux socks"
+
+RDEPEND="acct-user/fetchmail
+ ssl? ( >=dev-libs/openssl-3.0.9:= )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ app-alternatives/lex
+ nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-fetchmail )"
+
+REQUIRED_USE="kerberos? ( ssl )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}