summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-06-23 10:00:25 +0100
committerMatthew Smith <matthew@gentoo.org>2023-06-23 10:00:25 +0100
commit96d078148c3a2fcca9d8ac944ffe723129b3652e (patch)
treeddf6f533717077ddb38a5cefcbdaa706a7329b46 /net-mail
parentmedia-gfx/renderdoc: drop 1.24, security cleanup (diff)
downloadgentoo-96d078148c3a2fcca9d8ac944ffe723129b3652e.tar.gz
gentoo-96d078148c3a2fcca9d8ac944ffe723129b3652e.tar.bz2
gentoo-96d078148c3a2fcca9d8ac944ffe723129b3652e.zip
net-mail/mu: add 1.10.4
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.10.4.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 992c42af2681..6cb431e132b7 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
DIST mu-1.10.2.tar.xz 569692 BLAKE2B a75ad3d60806a5d336665b5dbc7d1f062928eff6fd2424651d3d85c4dd3134d1b4f912bd24120c14670dab49ef2e51056a0b130cc714edd0d56ab87bbdb7832b SHA512 2e8843846676c4f9ed9abb48bce8c52ffbfafcf1b7542c9f0663c2f5572c101871e935938f0406b284c6b78fb0fb190469d193151c5adbc50a10eea0edf76ccd
DIST mu-1.10.3.tar.xz 569740 BLAKE2B bfd332d77a0c8727beeac363c35199dd8da0b4dde940981845865eda7e0ff7a7bfcbfef76509ca407bea80b4b148b0b6bce79fa928b2c4df239b55325336c049 SHA512 dbc3946b50791bb01e640d7c07a5072c4c6381b576337899c32b0f0c8331b44ab328f3887eacfff4d5ec71144164a43dc2c1241330bf00226748485027e7f21b
+DIST mu-1.10.4.tar.xz 570024 BLAKE2B 81d0ea6ac018a24eaa9f80e21fdbd6f4e67faba1cf3d6f93721ac32caf1f820b03adfbee096229da95caf229f7dc3c8e78008654296fb684fdc62e0cffab590d SHA512 7c58ddf65c4aaa555d38c3a10ecf5d6e170ff2914515f8f1242ca59226bda09057bcbff2bc5459b448c34c3bd3add9546fd71387891f8eef8b2ee9aa738982e1
DIST mu-1.8.14.tar.xz 543828 BLAKE2B d64e52a66f3b68a2d5b039eaff668c5ecf0da8b1e77719de49316cbe96bb9d34c3e4f8636cfd63cf473218ea6ec428f8c2be2d80c94d1b1456e4b7f17c5ab52c SHA512 8d5514cf08891180163e4d7caff7a3d75dd39a6397c0c8608a85b613f83a4f714f772400c2a057c1f9ef46dedd4f240828ced4e8a1b38ebe4340041059a3ad44
diff --git a/net-mail/mu/mu-1.10.4.ebuild b/net-mail/mu/mu-1.10.4.ebuild
new file mode 100644
index 000000000000..2acec2e5ddb5
--- /dev/null
+++ b/net-mail/mu/mu-1.10.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Don't compress the info file.
+ sed -i '/gzip/d' build-aux/meson-install-info.sh || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature readline)
+ -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
+ # TODO: revisit this, it's not actually deprecated, just been reworked
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}