summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/topal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/topal')
-rw-r--r--net-mail/topal/Manifest1
-rw-r--r--net-mail/topal/files/75-Makefile.patch76
-rw-r--r--net-mail/topal/metadata.xml9
-rw-r--r--net-mail/topal/topal-75.ebuild42
4 files changed, 128 insertions, 0 deletions
diff --git a/net-mail/topal/Manifest b/net-mail/topal/Manifest
new file mode 100644
index 000000000000..78f1b6ab609c
--- /dev/null
+++ b/net-mail/topal/Manifest
@@ -0,0 +1 @@
+DIST topal-package-75.tgz 345976 SHA256 cc6da6fc4945d1fbd773eb01811fef4a23a7ac6bdc3c5a20c9cf33bb88ca70bd SHA512 fae4fdb1a10e8173ae233658337f3f6169637382289ad91bf1adb704bcaa10a7ce3a957015b0745034cacd5314b53e687650eee0868ca30cd176d5a255b21e64 WHIRLPOOL 987cdb6a979457bbaf25e341f8e22370a53838ad0b4c38c6185c12b5df13d50b3675051d4b6f4a0ead314565146070e413d4929a066b282cca3c035cf6193c73
diff --git a/net-mail/topal/files/75-Makefile.patch b/net-mail/topal/files/75-Makefile.patch
new file mode 100644
index 000000000000..54a4dc6316d1
--- /dev/null
+++ b/net-mail/topal/files/75-Makefile.patch
@@ -0,0 +1,76 @@
+--- MIME-tool/Makefile 2012-10-14 09:36:08.547372628 +0000
++++ MIME-tool/Makefile 2012-10-14 09:37:30.786356453 +0000
+@@ -1,10 +1,13 @@
+ .PHONY: all clean realclean distrib
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
+ all: mime-tool
+
+ mime-tool: mime.c
+- gcc -Wall -O2 -o mime-tool mime.c
+- -strip mime-tool
++ $(CC) $(CFLAGS) $(LDFLAGS) -o mime-tool mime.c
+
+ realclean: clean
+ -rm mime-tool
+--- Makefile 2012-10-14 10:01:35.211485438 +0000
++++ Makefile 2012-10-14 10:08:26.682400711 +0000
+@@ -15,6 +15,10 @@
+
+ .PHONY: all binary doc clean realclean distclean package install distrib all2 FORCE
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
+ RELEASECODE=$(shell grep '^<dt>' Changelog.html | tail -1 | sed 's/.* release //; sx</a>.*$$xx')
+ BUILDDATE=$(shell date '+%Y-%m-%dT%H%M%S%Z')
+
+@@ -44,20 +48,19 @@
+ all2: package distrib
+
+ ada-readline-c.o: ada-readline-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-readline-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-readline-c.c
+
+ ada-echo-c.o: ada-echo-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-echo-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-echo-c.c
+
+ externals-c.o: externals-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) externals-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) externals-c.c
+
+ mime-tool:
+- make -C MIME-tool
++ $(MAKE) -C MIME-tool
+
+ topal: $(TOPALDEPS)
+- gnatmake -gnat05 -gnatwa -gnato -O2 $(TOPALDEBUG) topal
+- -strip topal
++ gnatmake -gnat05 -gnatwa -gnato -O2 $(TOPALDEBUG) topal -largs $(LDFLAGS)
+
+ # FORCE, because BUILDDATE changes each time....
+ version_id.adb: mkversionid FORCE
+@@ -74,13 +77,13 @@
+ topal.pdf: topal.tex versionid.tex
+ pdflatex topal.tex && pdflatex topal.tex
+
+-install: all
++install:
+ install -d $(INSTALLPATHBIN) $(INSTALLPATHDOC) $(INSTALLPATHMAN)/man1 $(INSTALLPATHPATCHES)
+- install -m 755 -s topal $(INSTALLPATHBIN)
+- install -m 644 Features.html Changelog.html topal.pdf COPYING $(INSTALLPATHDOC)
++ install -m 755 topal $(INSTALLPATHBIN)
++ install -m 644 screens/*.png $(INSTALLPATHDOC)
+ install -m 644 topal.man $(INSTALLPATHMAN)/man1/topal.1
+- install -m 644 pine-*.patch alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
+- install -m 755 -s MIME-tool/mime-tool $(INSTALLPATHBIN)
++ install -m 644 alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
++ install -m 755 MIME-tool/mime-tool $(INSTALLPATHBIN)
+ install -m 644 MIME-tool/mime-tool.man $(INSTALLPATHMAN)/man1/mime-tool.1
+
+ clean:
diff --git a/net-mail/topal/metadata.xml b/net-mail/topal/metadata.xml
new file mode 100644
index 000000000000..8434a442ba8f
--- /dev/null
+++ b/net-mail/topal/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription lang="en">
+ Topal is a glue program that links GnuPG and Pine/Alpine. It offers
+ facilities to encrypt, decrypt, sign and verify emails.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-mail/topal/topal-75.ebuild b/net-mail/topal/topal-75.ebuild
new file mode 100644
index 000000000000..ea45e3c7aee9
--- /dev/null
+++ b/net-mail/topal/topal-75.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Topal is a 'glue' program that links GnuPG and Pine/Alpine"
+HOMEPAGE="http://homepage.ntlworld.com/phil.brooke/topal/"
+SRC_URI="http://homepage.ntlworld.com/phil.brooke/topal/rel-${PV}/topal-package-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=app-crypt/gnupg-2.0.7-r1
+ || ( net-mail/metamail app-misc/run-mailcap )
+ || ( app-text/dos2unix app-text/hd2u )
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/ada
+ doc? ( app-text/texlive )"
+
+src_prepare() {
+ rm "${S}"/MIME-tool/mime-tool || die
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ use doc || sed -i -e '/pdflatex/s/^/#/' Makefile
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install \
+ INSTALLPATH="${D}"/usr \
+ INSTALLPATHDOC="${D}/usr/share/doc/${PF}"
+ dohtml "${S}"/*.html
+}