summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-28 11:42:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-28 11:42:30 +0300
commit8d393c76a9277f3d09e57e0a7aecdf56c64ac469 (patch)
treea27edabcc8a88f736f5867125cf2605194d7370b /net-mail/postorius
parentdev-python/sphinxcontrib-doxylink: Add testfixtures dep (diff)
downloadgentoo-8d393c76a9277f3d09e57e0a7aecdf56c64ac469.tar.gz
gentoo-8d393c76a9277f3d09e57e0a7aecdf56c64ac469.tar.bz2
gentoo-8d393c76a9277f3d09e57e0a7aecdf56c64ac469.zip
net-mail/postorius: add 1.3.5, enable py3.9, enable tests
Bug: https://bugs.gentoo.org/812853 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-mail/postorius')
-rw-r--r--net-mail/postorius/Manifest1
-rw-r--r--net-mail/postorius/postorius-1.3.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/postorius/Manifest b/net-mail/postorius/Manifest
index fac3606d7c87..d4578faa729b 100644
--- a/net-mail/postorius/Manifest
+++ b/net-mail/postorius/Manifest
@@ -1 +1,2 @@
DIST postorius-1.3.3.tar.gz 2704738 BLAKE2B 0ae5a7b3ace1ad7f64eae53156592d0c76a09e358d08edfe1b506717e87df67c669bfab356c203e28c03006f46461a67b4c7222e0e305100e15511a93e3e6a59 SHA512 31d6d6d0dbbe8a57251c81cf8f7d8b80d17dd4aab9f31be684fef26637a4ba81a196d4ab63e7389bd4173a60778a00c83ee440c24f83a1f60b094ccab8cf345a
+DIST postorius-1.3.5.tar.gz 2775722 BLAKE2B 85f3408b7205ce4f89c36906280ff7ccecca0752ae611f4631e16d43972d0b52321be0f533fdabe6bf7d503120ab7a3794ef25f64a72369dec782b60347e33bb SHA512 f5f90ade87ae028fe665918b0aef69ac6c79f8d45ee4d105825ed9113661f084f3a82db9ac6ee850fa0feb5fd5afe7b66e49040d22c2e0599a95c3aa8ad56a31
diff --git a/net-mail/postorius/postorius-1.3.5.ebuild b/net-mail/postorius/postorius-1.3.5.ebuild
new file mode 100644
index 000000000000..18b4965e46dd
--- /dev/null
+++ b/net-mail/postorius/postorius-1.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A web user interface for GNU Mailman 3"
+HOMEPAGE="https://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/readme_renderer[${PYTHON_USEDEP}]
+ net-mail/django-mailman3[${PYTHON_USEDEP}]
+ net-mail/mailmanclient[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ net-mail/mailman[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's/test_list_info/_&/' -i src/postorius/tests/mailman_api_tests/test_list_summary.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTHONPATH="${S}/src"
+ cd example_project || die
+ epytest ../src
+}