summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/mpop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/mpop')
-rw-r--r--net-mail/mpop/Manifest3
-rw-r--r--net-mail/mpop/metadata.xml11
-rw-r--r--net-mail/mpop/mpop-1.0.29.ebuild77
-rw-r--r--net-mail/mpop/mpop-1.2.0.ebuild49
-rw-r--r--net-mail/mpop/mpop-1.2.2.ebuild49
5 files changed, 189 insertions, 0 deletions
diff --git a/net-mail/mpop/Manifest b/net-mail/mpop/Manifest
new file mode 100644
index 000000000000..5a725e556cc4
--- /dev/null
+++ b/net-mail/mpop/Manifest
@@ -0,0 +1,3 @@
+DIST mpop-1.0.29.tar.bz2 292369 SHA256 bd7409741629669969b176ed664e0adec449bf434b9f333e74fed534b28690b8 SHA512 fbb55bf2c83024cc4397f6f59c6977a5f77ab697bbcc508a5160cd74047b4c0b717c76970d760f413356efd0527da0c9a129f34a664fea080ad39f5cef16ccb1 WHIRLPOOL b450422ee343175940136abe3ba09a4ab16e7257a93c97ee0067fc5f43db6663ba12ce06bb5ce7a6f143bd3302390f13a0023dc6bc25152dae12f97a5bdcd808
+DIST mpop-1.2.0.tar.xz 264560 SHA256 9d28817a6950f64aadf10bf5841400701917102181ebf96c136fbd4707c17ba7 SHA512 f01d3d5f8e9b9fc70a8d774bb8669655573c23492f85191e5709aefc8ee9cde83e177f7803cd8cc0166fa5457f8566510655a8d47100d337ca17c8d543f450af WHIRLPOOL eeac66490fc74b203a79816622343ccab4c02cfd89dd433de5096ed182ede7a3b63c28daccdb986bd464d07863ed3a104f72a6913c020d8703eed0b608c8ab64
+DIST mpop-1.2.2.tar.xz 266272 SHA256 d1e7d7d18147996cfc6195cdfb936ca51620cb841a7460043d8cc838ca48bfc3 SHA512 5cb78ac088fa5da4e6c8f049510e0aab986b73f062b05169482adf6b14cb9abe04f93bd4672837c3b406880f86e4bbf6f5dd8c5b98b1bcad485ac43ea48ae7c7 WHIRLPOOL 81628892d46ca32086bdcd9a4608894d5f5f2b460340bc521592a146a017c41aef77f8e264277cb753ad9fd2ca33df83c60aae99b8d1f3a146cb12e860fea7a6
diff --git a/net-mail/mpop/metadata.xml b/net-mail/mpop/metadata.xml
new file mode 100644
index 000000000000..3b8d246714a8
--- /dev/null
+++ b/net-mail/mpop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="libsecret">Enable libsecret support to store login credentials</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">mpop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mpop/mpop-1.0.29.ebuild b/net-mail/mpop/mpop-1.0.29.ebuild
new file mode 100644
index 000000000000..44c026f19b02
--- /dev/null
+++ b/net-mail/mpop/mpop-1.0.29.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A small, fast, and portable POP3 client"
+HOMEPAGE="http://mpop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring gnutls idn nls sasl ssl vim-syntax"
+REQUIRED_USE="gnome-keyring? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ gnome-keyring? (
+ ${PYTHON_DEPS}
+ dev-python/gnome-keyring-python
+ gnome-base/libgnome-keyring
+ )
+ idn? ( net-dns/libidn )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
+
+src_configure() {
+ econf \
+ $(use_with gnome-keyring ) \
+ $(use_with idn libidn) \
+ $(use_enable nls) \
+ $(use_with sasl libgsasl) \
+ $(use_with ssl ssl $(usex gnutls "gnutls" "openssl"))
+}
+
+src_install() {
+ default
+
+ if use gnome-keyring ; then
+ src_install_contrib mpop-gnome-tool mpop-gnome-tool.py README
+ python_fix_shebang "${D}"/usr/share/${PN}/mpop-gnome-tool/mpop-gnome-tool.py
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+ fi
+}
+
+src_install_contrib() {
+ subdir="$1"
+ bins="$2"
+ docs="$3"
+ local dir=/usr/share/${PN}/$subdir
+ insinto ${dir}
+ exeinto ${dir}
+ for i in $bins ; do
+ doexe scripts/$subdir/$i
+ done
+ for i in $docs ; do
+ newdoc scripts/$subdir/$i $subdir.$i
+ done
+}
diff --git a/net-mail/mpop/mpop-1.2.0.ebuild b/net-mail/mpop/mpop-1.2.0.ebuild
new file mode 100644
index 000000000000..89b55c059c53
--- /dev/null
+++ b/net-mail/mpop/mpop-1.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A small, fast, and portable POP3 client"
+HOMEPAGE="http://mpop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls idn libsecret nls sasl ssl vim-syntax"
+
+RDEPEND="
+ idn? ( net-dns/libidn )
+ libsecret? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl ssl $(usex gnutls "gnutls" "openssl")) \
+ $(use_with sasl libgsasl) \
+ $(use_with idn libidn) \
+ $(use_with libsecret )
+}
+
+src_install() {
+ default
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+ fi
+}
diff --git a/net-mail/mpop/mpop-1.2.2.ebuild b/net-mail/mpop/mpop-1.2.2.ebuild
new file mode 100644
index 000000000000..89b55c059c53
--- /dev/null
+++ b/net-mail/mpop/mpop-1.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A small, fast, and portable POP3 client"
+HOMEPAGE="http://mpop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls idn libsecret nls sasl ssl vim-syntax"
+
+RDEPEND="
+ idn? ( net-dns/libidn )
+ libsecret? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl ssl $(usex gnutls "gnutls" "openssl")) \
+ $(use_with sasl libgsasl) \
+ $(use_with idn libidn) \
+ $(use_with libsecret )
+}
+
+src_install() {
+ default
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+ fi
+}