summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/asmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/asmail')
-rw-r--r--net-mail/asmail/Manifest1
-rw-r--r--net-mail/asmail/asmail-2.1.ebuild48
-rw-r--r--net-mail/asmail/files/asmail-2.1-ldflags.patch19
-rw-r--r--net-mail/asmail/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/net-mail/asmail/Manifest b/net-mail/asmail/Manifest
new file mode 100644
index 000000000000..224b6a76f61a
--- /dev/null
+++ b/net-mail/asmail/Manifest
@@ -0,0 +1 @@
+DIST asmail-2.1.tar.gz 271164 SHA256 9b20aff43d61511e9c24af5603a546e3709bad35c769074e2b66d818f33e8191
diff --git a/net-mail/asmail/asmail-2.1.ebuild b/net-mail/asmail/asmail-2.1.ebuild
new file mode 100644
index 000000000000..9f851938e3b2
--- /dev/null
+++ b/net-mail/asmail/asmail-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="a small mail monitor similar to xbiff"
+HOMEPAGE="http://www.tigr.net"
+SRC_URI="http://www.tigr.net/afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="jpeg"
+
+RDEPEND="dev-libs/openssl
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_compile() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -i -e "/LIB/s/-lssl/-lssl -lcrypto/g" \
+ configure
+ tc-export CC
+ econf $(use_enable jpeg)
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+
+ newman ${PN}.man ${PN}.1
+ newman ${PN}rc.man ${PN}rc.5
+
+ insinto /usr/share/${PN}/pixmaps
+ doins pixmaps/cloud-e/*.xpm
+
+ insinto /usr/share/${PN}
+ doins -r sounds
+
+ dodoc ${PN}rc.s* CHANGES *.txt README* TODO
+}
diff --git a/net-mail/asmail/files/asmail-2.1-ldflags.patch b/net-mail/asmail/files/asmail-2.1-ldflags.patch
new file mode 100644
index 000000000000..14d431c6da4b
--- /dev/null
+++ b/net-mail/asmail/files/asmail-2.1-ldflags.patch
@@ -0,0 +1,19 @@
+commit 89ac271856ad5ecc7bd38c5aabc393b41976aca2
+Author: Eray Aslan <eras@gentoo.org>
+Date: Tue Jun 7 18:11:43 2011 +0300
+
+ Respect LDFLAGS
+
+diff --git a/autoconf/Makefile.common.in b/autoconf/Makefile.common.in
+index de290d0..cebe471 100644
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -49,7 +49,7 @@ indent:
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c
diff --git a/net-mail/asmail/metadata.xml b/net-mail/asmail/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-mail/asmail/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>