summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-08-13 23:55:30 +0100
committerMarek Szuba <marecki@gentoo.org>2021-08-13 23:55:30 +0100
commitfd37af5f175f9afaaa691147a3e6335fac5a7cf5 (patch)
treea02947dbffd6cce8ae79cdec0ec78c31f84e6ffb /net-libs
parentdev-python/sip: drop 4.19.25 (diff)
downloadgentoo-fd37af5f175f9afaaa691147a3e6335fac5a7cf5.tar.gz
gentoo-fd37af5f175f9afaaa691147a3e6335fac5a7cf5.tar.bz2
gentoo-fd37af5f175f9afaaa691147a3e6335fac5a7cf5.zip
net-libs/nodejs: do not purge unneeded bundled dependencies
Turns out this breaks the install phase in at least v16. No idea how I've managed to get that one slip past my build testing - but there you go. Closes: https://bugs.gentoo.org/808063 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-12.22.5.ebuild8
-rw-r--r--net-libs/nodejs/nodejs-14.17.5.ebuild11
-rw-r--r--net-libs/nodejs/nodejs-16.6.2.ebuild11
3 files changed, 0 insertions, 30 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.5.ebuild b/net-libs/nodejs/nodejs-12.22.5.ebuild
index 19fc9cce0e0d..a8662cb49d0e 100644
--- a/net-libs/nodejs/nodejs-12.22.5.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.5.ebuild
@@ -88,14 +88,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
diff --git a/net-libs/nodejs/nodejs-14.17.5.ebuild b/net-libs/nodejs/nodejs-14.17.5.ebuild
index 14e49bf0eb0d..d819d8b826f4 100644
--- a/net-libs/nodejs/nodejs-14.17.5.ebuild
+++ b/net-libs/nodejs/nodejs-14.17.5.ebuild
@@ -81,17 +81,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-icu; then
- rm -r deps/icu-small || die "Failed to remove bundled ICU"
- fi
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
diff --git a/net-libs/nodejs/nodejs-16.6.2.ebuild b/net-libs/nodejs/nodejs-16.6.2.ebuild
index df3eeec96e62..44eb7d90f0a5 100644
--- a/net-libs/nodejs/nodejs-16.6.2.ebuild
+++ b/net-libs/nodejs/nodejs-16.6.2.ebuild
@@ -73,17 +73,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-icu; then
- rm -r deps/icu-small || die "Failed to remove bundled ICU"
- fi
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die