summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-12 12:15:41 +0100
committerSam James <sam@gentoo.org>2023-06-12 12:15:50 +0100
commite001732ca95030774eb78c68a4717ecbc7e74973 (patch)
treeb8569e840f45b8b037f1193f10fdb136ced005e1 /net-libs
parentnet-dialup/ppp: backport radiusclient.conf parsing fix (diff)
downloadgentoo-e001732ca95030774eb78c68a4717ecbc7e74973.tar.gz
gentoo-e001732ca95030774eb78c68a4717ecbc7e74973.tar.bz2
gentoo-e001732ca95030774eb78c68a4717ecbc7e74973.zip
net-libs/stem: add 1.8.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/stem/Manifest1
-rw-r--r--net-libs/stem/stem-1.8.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index 4eb8deaa4f10..8e45a8395e6e 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1 +1,2 @@
DIST stem-1.8.1.tar.gz 2859634 BLAKE2B f78da079791583a17eb439a4e2459c7e0af454e45300202df1085d1b1ba150ee097cfa1b93df5ad0d7090644fad6e035604382c73b94744076cad490ab52459a SHA512 bad2f4f96e37caa3ee2928bb027318c4941ca3f6c0072c5f6e87fe647d2b68400ad352d9c27fa2a35c00f4f327aa9cc00e2907b21a9cbd26fab46ec21e2a038a
+DIST stem-1.8.2.tar.gz 2859640 BLAKE2B 4539fc42a463cd1c2ebba10bb31a69d529c41cdaee623beebd3219a2c1d59f8f9b8242b537dd4244e666fb765c5af2729caeeb22a7f8cd1ca6c13dd3cf6aac93 SHA512 f054bbc9a61e04fb7e3b7d1534803b938b855c29795471953661f8fd9c0a5196fe1f9ccfd01e5b3256ea42893a7d57fda34fa54932012e345f74bb3303ff98c5
diff --git a/net-libs/stem/stem-1.8.2.ebuild b/net-libs/stem/stem-1.8.2.ebuild
new file mode 100644
index 000000000000..8cfdad4fb4db
--- /dev/null
+++ b/net-libs/stem/stem-1.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="net-vpn/tor"
+BDEPEND="test? ( net-vpn/tor )"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{api,change_log,contents,download,faq,index,tutorials}.rst} )
+
+PATCHES=(
+ # https://github.com/torproject/stem/issues/53
+ "${FILESDIR}"/1.8.1-Add-an-exclude-test-argument.patch
+)
+
+python_prepare_all() {
+ # https://github.com/torproject/stem/issues/56
+ sed -i '/MOCK_VERSION/d' run_tests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ --exclude-test test.integ.installation.TestInstallation.test_install
+ --exclude-test test.integ.util.system.TestSystem.test_expand_path
+ --exclude-test test.integ.control.controller.TestController.test_get_listeners
+ --exclude-test test.integ.control.controller.TestController.test_get_ports
+ --exclude-test test.integ.control.controller.TestController.test_getinfo_freshrelaydescs
+ # confused by exception text change for JSON parsing
+ --exclude-test test.unit.descriptor.collector.TestCollector.test_index_malformed_json
+ )
+
+ # We use --unit --integ to avoid the static/style/lint checks.
+ ${EPYTHON} run_tests.py --verbose --unit --integ "${skipped_tests[@]}" || die "Tests failed with ${EPYTHON}"
+}