summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-11-06 20:41:35 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-11-06 21:17:22 -0500
commitdba22f412e7dfc4e0e196ac23d432f1556d1d1b7 (patch)
tree9f410ae85d38c766f976ffe128ea740b28024c90 /net-libs
parentnet-im/discord: add 0.0.34, drop 0.0.33 (diff)
downloadgentoo-dba22f412e7dfc4e0e196ac23d432f1556d1d1b7.tar.gz
gentoo-dba22f412e7dfc4e0e196ac23d432f1556d1d1b7.tar.bz2
gentoo-dba22f412e7dfc4e0e196ac23d432f1556d1d1b7.zip
net-libs/zeromq: add 4.3.5
Miscellaneous changes: * Update to EAPI=8 * Drop obsolete USE=pgm flag * Use --disable-Werror instead of sed'ing configure.ac * New MPL-2.0 license (from their NEWS file) * Improve DESCRIPTION Bug: https://bugs.gentoo.org/806821 Closes: https://bugs.gentoo.org/805566 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zeromq/Manifest1
-rw-r--r--net-libs/zeromq/zeromq-4.3.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/zeromq/Manifest b/net-libs/zeromq/Manifest
index 59db8d2e153a..277b438efc89 100644
--- a/net-libs/zeromq/Manifest
+++ b/net-libs/zeromq/Manifest
@@ -1,2 +1,3 @@
DIST zeromq-4.3.3.tar.gz 2117050 BLAKE2B 69bd1544fa76232ecf860b364592762c4170c327c444bf79a916947e1c370eb8c6c20b2ae271374d70bde11db9116ef6a64262e287982e5f41d6a5029649348f SHA512 4c18d784085179c5b1fcb753a93813095a12c8d34970f2e1bfca6499be6c9d67769c71c68b7ca54ff181b20390043170e89733c22f76ff1ea46494814f7095b1
DIST zeromq-4.3.4.tar.gz 2486520 BLAKE2B 3c10989a9359a79317adaa8bf6e138357196b82078656911437ee848a347759acc1ef49feda5e1a8912974026e55907b9ffd5172111ddb83ba8cf92dd6715379 SHA512 e198ef9f82d392754caadd547537666d4fba0afd7d027749b3adae450516bcf284d241d4616cad3cb4ad9af8c10373d456de92dc6d115b037941659f141e7c0e
+DIST zeromq-4.3.5.tar.gz 2530237 BLAKE2B 1ece80f4d4f6bba401c9801105cb9adecdde28c619035970a5d8e75ae4617e023c89857ef81179331cbe23b9bb69a0c15904ce9099fa59440829fb5986348d7e SHA512 a71d48aa977ad8941c1609947d8db2679fc7a951e4cd0c3a1127ae026d883c11bd4203cf315de87f95f5031aec459a731aec34e5ce5b667b8d0559b157952541
diff --git a/net-libs/zeromq/zeromq-4.3.5.ebuild b/net-libs/zeromq/zeromq-4.3.5.ebuild
new file mode 100644
index 000000000000..c49001773457
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.3.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="High-performance asynchronous messaging library"
+HOMEPAGE="https://zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="doc drafts +libbsd +sodium static-libs test unwind"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ libbsd? ( dev-libs/libbsd:= )
+ sodium? ( dev-libs/libsodium:= )
+"
+DEPEND="
+ ${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+"
+BDEPEND="
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-Werror
+ --enable-shared
+ $(use_enable drafts)
+ $(use_enable libbsd)
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}