summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-10-26 14:11:26 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-10-27 08:42:16 +0200
commitda3bd28696a64f3eb8113f789db8a98df672d423 (patch)
tree7b8ce6a2ffd0542337cbae4962f6ba09a4873974 /net-libs
parentnet-libs/davix: drop 0.8.3 (diff)
downloadgentoo-da3bd28696a64f3eb8113f789db8a98df672d423.tar.gz
gentoo-da3bd28696a64f3eb8113f789db8a98df672d423.tar.bz2
gentoo-da3bd28696a64f3eb8113f789db8a98df672d423.zip
net-libs/pacparser: add 1.4.2
Note: patches dropped since they were merged upstream. See https://github.com/manugarg/pacparser/pull/136. Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pacparser/Manifest1
-rw-r--r--net-libs/pacparser/pacparser-1.4.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/pacparser/Manifest b/net-libs/pacparser/Manifest
index a74af7829e92..bf811da3e8c4 100644
--- a/net-libs/pacparser/Manifest
+++ b/net-libs/pacparser/Manifest
@@ -1 +1,2 @@
DIST pacparser-1.4.0.tar.gz 902919 BLAKE2B da29b34654764b1569d9d37648e4ccb608142becaf34c65cdf37b2bd81aa073b1945d840fb50aa7cb986687bbdc086c862a05bc421adb08d44e1add637b712ed SHA512 9574068dc4da3db27ddc1242cf98d98ebc7515864789e95b700cd2ce1433a7cff84160f1507976488fab7529839cabe9cf2aa16ddbefc0c83009fa6c0d2ad6b3
+DIST pacparser-1.4.2.tar.gz 903425 BLAKE2B 6b46fd87487feacb3915ddd3705eb60f795257adc5361fddbfc550c537471276f464f367b57124efc49f57666f232c297df763f2adea34d7642bd1e3271f47b4 SHA512 65d12421ee79a969b867d7dcec1527ac9b2596c25f6be2502742ba1b3788f05afeed2fcd5406dfb39485d1d56ef161684acabe6a95008725385c3c5336f331b1
diff --git a/net-libs/pacparser/pacparser-1.4.2.ebuild b/net-libs/pacparser/pacparser-1.4.2.ebuild
new file mode 100644
index 000000000000..e3cd424765ae
--- /dev/null
+++ b/net-libs/pacparser/pacparser-1.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Library to parse proxy auto-config files"
+HOMEPAGE="http://pacparser.manugarg.com/"
+SRC_URI="https://github.com/manugarg/${PN}/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# spidermonkey-1.7.0 is bundled
+# tested unbundling with spidermonkey-1.8* and 1.7
+# and got many failures: unbundling not worth it.
+
+src_prepare() {
+ default
+
+ sed -e '/CC = gcc/d' \
+ -i src/spidermonkey/js/src/config/Linux_All.mk || die
+
+ export NO_INTERNET=yes
+ export VERSION="${PV}"
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ # Upstream parallel compilation bug, do that first to work around
+ emake -C src/spidermonkey
+ emake -C src
+ use python && python_foreach_impl emake -C src pymod
+}
+
+src_install() {
+ emake \
+ LIB_PREFIX="${ED}/usr/$(get_libdir)" \
+ DOC_PREFIX="${ED}/usr/share/doc/${PF}" \
+ BIN_PREFIX="${ED}"/usr/bin \
+ INC_PREFIX="${ED}"/usr/include \
+ MAN_PREFIX="${ED}"/usr/share/man \
+ -C src install
+ dodoc README.md
+
+ if use python; then
+ python_foreach_impl emake DESTDIR="${D}" -C src install-pymod
+ python_foreach_impl python_optimize
+ fi
+
+ if use doc; then
+ docompress -x /usr/share/doc/${PF}/{html,examples}
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/{html,examples} || die
+ fi
+}