summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-18 20:06:34 -0400
committerSam James <sam@gentoo.org>2024-03-19 03:20:48 +0000
commitb653d41a1077898b62abcb96ab8980f30c930521 (patch)
treed1a16de1e9f2a44d3e9bf140e64171bb5ec061a3 /net-libs
parentdev-lang/f2c: update EAPI 7 -> 8 (diff)
downloadgentoo-b653d41a1077898b62abcb96ab8980f30c930521.tar.gz
gentoo-b653d41a1077898b62abcb96ab8980f30c930521.tar.bz2
gentoo-b653d41a1077898b62abcb96ab8980f30c930521.zip
net-libs/enet: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/enet/enet-1.3.17.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-libs/enet/enet-1.3.17.ebuild b/net-libs/enet/enet-1.3.17.ebuild
index 73fe10687078..e3d3d51f4903 100644
--- a/net-libs/enet/enet-1.3.17.ebuild
+++ b/net-libs/enet/enet-1.3.17.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit libtool
+
DESCRIPTION="Relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/ https://github.com/lsalzman/enet/"
SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
@@ -14,6 +16,11 @@ IUSE="static-libs"
RDEPEND="!${CATEGORY}/${PN}:0"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}