summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-01-18 09:06:01 -0500
committerCraig Andrews <candrews@gentoo.org>2022-01-18 09:06:11 -0500
commita848ac841bb91d98fd1957f0828baee23cff45f9 (patch)
tree53f24945d6b8f6ac23f0b6c031f87b1b4ce49410 /net-libs
parentsci-mathematics/lcalc: remove old "unused" lcalc-2.0.3.ebuild. (diff)
downloadgentoo-a848ac841bb91d98fd1957f0828baee23cff45f9.tar.gz
gentoo-a848ac841bb91d98fd1957f0828baee23cff45f9.tar.bz2
gentoo-a848ac841bb91d98fd1957f0828baee23cff45f9.zip
net-libs/ngtcp2: 0.1.0 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index 736d30a78734..c2d6b70d475d 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1 +1,2 @@
+DIST ngtcp2-0.1.0.tar.xz 540132 BLAKE2B df59b4632110f118e0ae27c709fee24be65216d5461ad73901fb7f7450afe17a255acda10473a39ac45a34c2810728c50e39dcde9a71c48eb843d5d628b70b8c SHA512 935c37fe08bb625b39d4355322df54cedc180584c46b7816a84b2715f777a49590cd0434ed062fabec55df1a2c5332e7edf6335bd071599b053d6f404ce260b8
DIST ngtcp2-0_pre20190912.tar.gz 302984 BLAKE2B 906b248b0c19395288ed2c5ad55c8d42a9df9d76458104785c1013b9ebfaf1b92a4b87ced8755377fcb627018cf8854be0e4687e4c8a23ae994e5a21f466f739 SHA512 91b93575143960af421e8bd37d686602905fa3093750cfbbe3af1b20d743318281d22162676dc451562768ca08b6d0767b1dc28f3f8f6733235ebd76015a05bb
diff --git a/net-libs/ngtcp2/ngtcp2-0.1.0.ebuild b/net-libs/ngtcp2/ngtcp2-0.1.0.ebuild
new file mode 100644
index 000000000000..7e8e166f726a
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="ssl test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenSSL=$(usex !ssl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}