summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-03 05:49:30 +0000
committerSam James <sam@gentoo.org>2024-03-03 05:49:30 +0000
commit97fc44852d225d13cc8f60030ddf30c1e30552df (patch)
tree70e901f84699d4d8aafc3f95979ca674192f171a /net-libs
parentsys-libs/pam_wrapper: add 1.1.5 (diff)
downloadgentoo-97fc44852d225d13cc8f60030ddf30c1e30552df.tar.gz
gentoo-97fc44852d225d13cc8f60030ddf30c1e30552df.tar.bz2
gentoo-97fc44852d225d13cc8f60030ddf30c1e30552df.zip
net-libs/socket_wrapper: add 1.4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/socket_wrapper/Manifest1
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.4.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index 66d1f6662ab1..1d4c04730ed3 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1,2 +1,3 @@
DIST socket_wrapper-1.3.4.tar.gz 81997 BLAKE2B 5d290ef59c16fbdde362749196cc91c3f050518f82cb14fbafa3e00d5fb51a6b085b94b08413ca601731440d8eadb5dfbe8d011567fd67b1240b0cc380504813 SHA512 6e6a940e26d0f4dc4f1c0f84643d5a124bb2cccd1713481e9c42ea7986884928d736b1ef8da8a2aef3d3803938b6e1ebd30bdbe9784fda95a9a59cdbd1d19f61
DIST socket_wrapper-1.4.0.tar.gz 87353 BLAKE2B 67c2a4bae2e1031399137e404e95e6e6cfa1143ff659a7d34533e908f9169b8a79d1dfffaa51a6280a8cfc9e03dc07585ff41b0e087527b1ad0bb5adb282156e SHA512 944e5ff2b6919e414f9045fe294b9b4813272fe7c00f5ac144c999b99572be6b3ed2eb975ec1d07bd853cffea6dffe339280e4961520d34667f808f76b47db57
+DIST socket_wrapper-1.4.2.tar.gz 90641 BLAKE2B 8a43f48ed8f3809eac8c86ee55e740ac37068d729f3f36955b9f017f29c40fa86f1f4455d2e33c8bb9413e25d8e7cb4bab84cd2688f54febb17d41c37ceb4d79 SHA512 30de1dfa6bfae51114b0557a00b87c785b7a00cf62d495b5c4bd837f32016ed58f942e7de0c33d09aa72e533f58283af6b5ae50f276ad7e58e853e32a8400024
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.4.2.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.4.2.ebuild
new file mode 100644
index 000000000000..616af852b9e3
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ # https://gcc.gnu.org/PR46596
+ # https://gcc.gnu.org/PR101270
+ filter-flags -fno-semantic-interposition
+
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}
+
+src_test() {
+ ewarn "test_echo_tcp_poll takes a while to run!"
+ cmake_src_test
+}