summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-01 16:56:31 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-10-08 11:19:56 +0300
commit6c55e3cb057abcb3846ef119189ceee2669f1ff1 (patch)
treea2152a3ad541feed03043131e9c1b3040f5e5fdb /net-libs
parentnet-misc/econnman: add python-3.11, python-3.12 compatibility (diff)
downloadgentoo-6c55e3cb057abcb3846ef119189ceee2669f1ff1.tar.gz
gentoo-6c55e3cb057abcb3846ef119189ceee2669f1ff1.tar.bz2
gentoo-6c55e3cb057abcb3846ef119189ceee2669f1ff1.zip
net-libs/libesmtp: Fix call to undeclared function strlcpy
And update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/896056 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33149 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libesmtp/files/libesmtp-1.1.0-fix-build-with-clang16.patch21
-rw-r--r--net-libs/libesmtp/libesmtp-1.1.0-r2.ebuild46
2 files changed, 67 insertions, 0 deletions
diff --git a/net-libs/libesmtp/files/libesmtp-1.1.0-fix-build-with-clang16.patch b/net-libs/libesmtp/files/libesmtp-1.1.0-fix-build-with-clang16.patch
new file mode 100644
index 000000000000..3211737e7be9
--- /dev/null
+++ b/net-libs/libesmtp/files/libesmtp-1.1.0-fix-build-with-clang16.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/896056
+--- a/smtp-api.c
++++ b/smtp-api.c
+@@ -22,6 +22,7 @@
+
+ #include <config.h>
+
++#define _GNU_SOURCE
+ #include <stdarg.h>
+ #include <string.h>
+ #include <stdlib.h>
+--- a/smtp-tls.c
++++ b/smtp-tls.c
+@@ -47,6 +47,7 @@
+
+ /* This stuff doesn't belong here */
+ /* vvvvvvvvvvv */
++#define _GNU_SOURCE
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/net-libs/libesmtp/libesmtp-1.1.0-r2.ebuild b/net-libs/libesmtp/libesmtp-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..35783f626e67
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.1.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Lib that implements the client side of the SMTP protocol"
+HOMEPAGE="https://libesmtp.github.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libesmtp/libESMTP.git"
+else
+ SRC_URI="https://github.com/libesmtp/libESMTP/archive/v${PV/_}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libESMTP-${PV}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# 0/7 was a snapshot before 1.1.0
+# The SONAME was fixed just before the 1.1.0 release was made
+# ... but a patch was needed to get it exactly right too
+# so, we're on 0/8 now, even though ABI compatibility actually remained
+# in terms of symbols with the original <1.1.0.
+SLOT="0/8"
+IUSE="ssl static-libs threads"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-1.1.0:0= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/{authors,bugreport,ChangeLog,faq,NEWS}.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-soname.patch
+ "${FILESDIR}"/${P}-fix-build-with-clang16.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ $(meson_feature ssl tls)
+ $(meson_feature threads pthreads)
+ )
+ meson_src_configure
+}