summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-25 00:35:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-25 02:27:42 +0200
commit631d600938028f332599ba699c34cbe1041d4733 (patch)
tree0a814a0219cb6088cb3fc047d6705bbe5da3eb88 /net-libs
parentkde-apps/okular: Drop 20.04.3 (r0) and 20.08.2 (r0) (diff)
downloadgentoo-631d600938028f332599ba699c34cbe1041d4733.tar.gz
gentoo-631d600938028f332599ba699c34cbe1041d4733.tar.bz2
gentoo-631d600938028f332599ba699c34cbe1041d4733.zip
net-libs/signon-ui: Don't use -fno-rtti, replace sed with patch
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/signon-ui/files/signon-ui-0.15_p20171022-disable-tests.patch24
-rw-r--r--net-libs/signon-ui/files/signon-ui-0.15_p20171022-drop-fno-rtti.patch28
-rw-r--r--net-libs/signon-ui/signon-ui-0.15_p20171022-r1.ebuild56
3 files changed, 108 insertions, 0 deletions
diff --git a/net-libs/signon-ui/files/signon-ui-0.15_p20171022-disable-tests.patch b/net-libs/signon-ui/files/signon-ui-0.15_p20171022-disable-tests.patch
new file mode 100644
index 000000000000..dc818cd15266
--- /dev/null
+++ b/net-libs/signon-ui/files/signon-ui-0.15_p20171022-disable-tests.patch
@@ -0,0 +1,24 @@
+From 468e47402334ce1a0eee9ce30c2e55951877d668 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 25 Oct 2020 00:11:12 +0200
+Subject: [PATCH] Disable unit tests
+
+---
+ tests/tests.pro | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/tests.pro b/tests/tests.pro
+index 6b37001..c711f56 100644
+--- a/tests/tests.pro
++++ b/tests/tests.pro
+@@ -1,7 +1,5 @@
+ TEMPLATE = subdirs
+ CONFIG += ordered
+-SUBDIRS = \
+- unit
+
+ CONFIG(medium-tests) {
+ SUBDIRS += functional
+--
+2.29.1
+
diff --git a/net-libs/signon-ui/files/signon-ui-0.15_p20171022-drop-fno-rtti.patch b/net-libs/signon-ui/files/signon-ui-0.15_p20171022-drop-fno-rtti.patch
new file mode 100644
index 000000000000..5360fd5b1ec7
--- /dev/null
+++ b/net-libs/signon-ui/files/signon-ui-0.15_p20171022-drop-fno-rtti.patch
@@ -0,0 +1,28 @@
+From 4546eeb26b79975259819795466320fa53676801 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 25 Oct 2020 00:06:03 +0200
+Subject: [PATCH] Don't use -fno-rtti
+
+---
+ common-project-config.pri | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/common-project-config.pri b/common-project-config.pri
+index 3206471..c05522f 100644
+--- a/common-project-config.pri
++++ b/common-project-config.pri
+@@ -4,10 +4,7 @@
+
+ CONFIG += link_pkgconfig
+
+-# we don't like warnings...
+-QMAKE_CXXFLAGS -= -Werror -Wno-write-strings
+-# Disable RTTI
+-QMAKE_CXXFLAGS += -fno-exceptions -fno-rtti
++QMAKE_CXXFLAGS += -fno-exceptions
+
+ TOP_SRC_DIR = $$PWD
+ TOP_BUILD_DIR = $${TOP_SRC_DIR}/$(BUILD_DIR)
+--
+2.29.1
+
diff --git a/net-libs/signon-ui/signon-ui-0.15_p20171022-r1.ebuild b/net-libs/signon-ui/signon-ui-0.15_p20171022-r1.ebuild
new file mode 100644
index 000000000000..bc10be56a15e
--- /dev/null
+++ b/net-libs/signon-ui/signon-ui-0.15_p20171022-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=4368bb77d9d1abc2978af514225ba4a42c29a646
+inherit qmake-utils
+
+DESCRIPTION="Online accounts signon UI"
+HOMEPAGE="https://gitlab.com/accounts-sso/signon-ui"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/${COMMIT}/${PN}-${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-qt/qttest:5 )"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtwebengine:5
+ dev-qt/qtwidgets:5
+ net-libs/accounts-qt
+ net-libs/libproxy
+ net-libs/signond
+ x11-libs/libnotify
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtwebchannel:5
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ # thanks to openSUSE
+ "${FILESDIR}/${P}-webengine-cachedir-path.patch"
+ "${FILESDIR}/${P}-fix-username-field-reading.patch"
+ # downstream
+ "${FILESDIR}/${P}-drop-fno-rtti.patch"
+ "${FILESDIR}/${P}-disable-tests.patch"
+)
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}