summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGavin D. Howard <gavin@gavinhoward.com>2023-05-28 16:12:16 -0600
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 13:35:20 +0200
commit57b9aa77f65846166b21451a1773257a5432b4ad (patch)
treeaaff01b67f109a2c557e29a9a17086978cd1177e /net-libs
parentdev-libs/libqtolm: Wire up testing (by improving upstream's cmake) (diff)
downloadgentoo-57b9aa77f65846166b21451a1773257a5432b4ad.tar.gz
gentoo-57b9aa77f65846166b21451a1773257a5432b4ad.tar.bz2
gentoo-57b9aa77f65846166b21451a1773257a5432b4ad.zip
net-libs/libquotient: Enable E2EE
This is the last step in enabling E2EE for Neochat. Signed-off-by: Gavin D. Howard <gavin@gavinhoward.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/libquotient-0.7.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.2-r1.ebuild b/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..30724041779e
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libqtolm
+ dev-libs/olm
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=OFF
+ -DQuotient_ENABLE_E2EE=ON
+ )
+ cmake_src_configure
+}