summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:16:03 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:01 +0100
commit52a2bdffaf95083bc4e80a941cba49e6ed953674 (patch)
treebeedfb2f6e80f5b18a58432d8abdd7f1f272add6 /net-libs
parentnet-analyzer/nagircbot: respect PKG_CONFIG (diff)
downloadgentoo-52a2bdffaf95083bc4e80a941cba49e6ed953674.tar.gz
gentoo-52a2bdffaf95083bc4e80a941cba49e6ed953674.tar.bz2
gentoo-52a2bdffaf95083bc4e80a941cba49e6ed953674.zip
net-libs/openmq-cclient: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/openmq-cclient/files/Makefile.in-44
-rw-r--r--net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/openmq-cclient/files/Makefile.in-4 b/net-libs/openmq-cclient/files/Makefile.in-4
index 8d536b927566..188f5ed472da 100644
--- a/net-libs/openmq-cclient/files/Makefile.in-4
+++ b/net-libs/openmq-cclient/files/Makefile.in-4
@@ -18,8 +18,8 @@ LTCC = $(LIBTOOL) --mode=compile --tag=CC $(CC)
LTCXX = $(LIBTOOL) --mode=compile --tag=CXX $(CXX)
LTLD = $(LIBTOOL) --mode=link --tag=CXX $(CXX)
-NS_S_PR_CFLAGS = $(shell pkg-config --cflags nss nspr)
-NS_S_PR_LIBS = $(shell pkg-config --libs nss nspr)
+NS_S_PR_CFLAGS = $(shell ${PKG_CONFIG} --cflags nss nspr)
+NS_S_PR_LIBS = $(shell ${PKG_CONFIG} --libs nss nspr)
SRCS = $(shell find "$(top_srcdir)" -name examples -prune -o -type f '(' -name '*.cpp' -o -name '*.c' -not -name '*Test*' ')')
LTOBJS = $(subst .c,.lo,$(subst .cpp,.lo,$(SRCS)))
diff --git a/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild b/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild
index 11ea9ac736ca..4cd376fd7ca6 100644
--- a/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild
+++ b/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit autotools epatch versionator
+inherit autotools epatch toolchain-funcs versionator
DESCRIPTION="C-Client Library for Open Source Java Message Service (JMS)"
HOMEPAGE="https://mq.java.net/"
@@ -14,7 +14,6 @@ MY_BUILDV="b7"
LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
if [[ $(x=( $(get_all_version_components) ); echo ${x[3]}) == '.' ]]; then
MY_PV=$(replace_version_separator 2 'u' $(get_version_component_range 1-3))
@@ -79,6 +78,7 @@ src_prepare() {
}
src_configure() {
+ tc-export PKG_CONFIG
econf --disable-static
}