summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:18:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:15 +0100
commit10298ffbe60e5cfcaf8927b8ab91416bee4a5231 (patch)
treef51aebee8bc6a6e2db06c3acfed82eaf868e9567 /net-libs
parentMove {sys-libs → llvm-runtimes}/compiler-rt-sanitizers (diff)
downloadgentoo-10298ffbe60e5cfcaf8927b8ab91416bee4a5231.tar.gz
gentoo-10298ffbe60e5cfcaf8927b8ab91416bee4a5231.tar.bz2
gentoo-10298ffbe60e5cfcaf8927b8ab91416bee4a5231.zip
Move {sys-libs → llvm-runtimes}/compiler-rt
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-18.20.4.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-18.20.5.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-20.15.1.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-20.17.0.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-20.18.0.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-20.18.1.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-22.10.0.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-22.12.0.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-22.4.1-r1.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-22.7.0.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-22.8.0.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild2
12 files changed, 16 insertions, 16 deletions
diff --git a/net-libs/nodejs/nodejs-18.20.4.ebuild b/net-libs/nodejs/nodejs-18.20.4.ebuild
index 2e4b995390a1..a913d96e2507 100644
--- a/net-libs/nodejs/nodejs-18.20.4.ebuild
+++ b/net-libs/nodejs/nodejs-18.20.4.ebuild
@@ -114,7 +114,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-18.20.5.ebuild b/net-libs/nodejs/nodejs-18.20.5.ebuild
index 15c26d15e9c0..f82847e3508a 100644
--- a/net-libs/nodejs/nodejs-18.20.5.ebuild
+++ b/net-libs/nodejs/nodejs-18.20.5.ebuild
@@ -114,7 +114,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-20.15.1.ebuild b/net-libs/nodejs/nodejs-20.15.1.ebuild
index 79e4dcce8bc0..738cf235d144 100644
--- a/net-libs/nodejs/nodejs-20.15.1.ebuild
+++ b/net-libs/nodejs/nodejs-20.15.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -113,7 +113,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-20.17.0.ebuild b/net-libs/nodejs/nodejs-20.17.0.ebuild
index 44f8a7a5ea5b..190648817a15 100644
--- a/net-libs/nodejs/nodejs-20.17.0.ebuild
+++ b/net-libs/nodejs/nodejs-20.17.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -113,7 +113,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-20.18.0.ebuild b/net-libs/nodejs/nodejs-20.18.0.ebuild
index 1a9f823fb862..a06c32bdae99 100644
--- a/net-libs/nodejs/nodejs-20.18.0.ebuild
+++ b/net-libs/nodejs/nodejs-20.18.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -113,7 +113,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-20.18.1.ebuild b/net-libs/nodejs/nodejs-20.18.1.ebuild
index 1a9f823fb862..a06c32bdae99 100644
--- a/net-libs/nodejs/nodejs-20.18.1.ebuild
+++ b/net-libs/nodejs/nodejs-20.18.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -113,7 +113,7 @@ src_configure() {
filter-lto
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-22.10.0.ebuild b/net-libs/nodejs/nodejs-22.10.0.ebuild
index f0eda09aff2b..e1343e263acb 100644
--- a/net-libs/nodejs/nodejs-22.10.0.ebuild
+++ b/net-libs/nodejs/nodejs-22.10.0.ebuild
@@ -127,7 +127,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-22.12.0.ebuild b/net-libs/nodejs/nodejs-22.12.0.ebuild
index f0eda09aff2b..e1343e263acb 100644
--- a/net-libs/nodejs/nodejs-22.12.0.ebuild
+++ b/net-libs/nodejs/nodejs-22.12.0.ebuild
@@ -127,7 +127,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-22.4.1-r1.ebuild b/net-libs/nodejs/nodejs-22.4.1-r1.ebuild
index 9dce8c018258..3e3cf32b4b5f 100644
--- a/net-libs/nodejs/nodejs-22.4.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-22.4.1-r1.ebuild
@@ -124,7 +124,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-22.7.0.ebuild b/net-libs/nodejs/nodejs-22.7.0.ebuild
index da3ea85862a7..51e02b2bcfe1 100644
--- a/net-libs/nodejs/nodejs-22.7.0.ebuild
+++ b/net-libs/nodejs/nodejs-22.7.0.ebuild
@@ -127,7 +127,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-22.8.0.ebuild b/net-libs/nodejs/nodejs-22.8.0.ebuild
index d3115842c733..783214a446b3 100644
--- a/net-libs/nodejs/nodejs-22.8.0.ebuild
+++ b/net-libs/nodejs/nodejs-22.8.0.ebuild
@@ -127,7 +127,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index f0eda09aff2b..e1343e263acb 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -127,7 +127,7 @@ src_configure() {
use arm64 && append-flags $(test-flags-CXX -mbranch-protection=none)
# nodejs unconditionally links to libatomic #869992
# specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
+ # is not yet implemented by llvm-runtimes/compiler-rt (see
# https://reviews.llvm.org/D85044?id=287068), therefore
# we depend on gcc and force using libgcc as the support lib
tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"