summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2024-06-08 11:44:27 +0300
committerSam James <sam@gentoo.org>2024-06-09 16:55:19 +0100
commit000ec6f45221f09506a44722d98b7d015acda89a (patch)
treeccd875401774171c6cf9c7365fd7edaabffe0edd /net-libs
parentgames-strategy/darwinia: EAPI 8, various tweaks (diff)
downloadgentoo-000ec6f45221f09506a44722d98b7d015acda89a.tar.gz
gentoo-000ec6f45221f09506a44722d98b7d015acda89a.tar.bz2
gentoo-000ec6f45221f09506a44722d98b7d015acda89a.zip
net-libs/nDPI: add a new version 4.8
Closes: https://bugs.gentoo.org/933818 Signed-off-by: Denis Pronin <dannftk@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nDPI/Manifest1
-rw-r--r--net-libs/nDPI/nDPI-4.8.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/nDPI/Manifest b/net-libs/nDPI/Manifest
index cc2200b5f302..7c4fb21e62ba 100644
--- a/net-libs/nDPI/Manifest
+++ b/net-libs/nDPI/Manifest
@@ -1,3 +1,4 @@
DIST nDPI-4.2.tar.gz 126559327 BLAKE2B 079267939083e788ce8b13e89b194504031e4c3e628df335ece7aab72cc80b8d8538badd45dac9fdaeeed8cd5dd19a81fece9c1157cba9a91dfa130abef61473 SHA512 c58b228b7de2b5fa111234bb065f9be259cd0282d0058f5985180aab6567c9a18e3453ce9062bd3c057a096ec3dfdc21b7c9680e0148e34af10f707530d853b8
DIST nDPI-4.4.tar.gz 151062073 BLAKE2B fca968c0d0abcf18a6895dc6066b754925a2aa3cb3f395383f9add25066adf14bb95444a30950e13f7f22223ff203b16e7373c875841f33d8c885be83ed0bb6d SHA512 c5e3d38f7b6533bd4b9f96520c1d965bf0a8e3ec7e2d514bc42683bdb73d8331e28ed695f5d3972ace9e35f1af23359f5a25c0f5a20f7a8cc7a6b5446d592468
DIST nDPI-4.6.tar.gz 29705235 BLAKE2B 65efdfee7af83093b08897fb726a07cf804a3ff901e7373cdc4b3d4564bbfba6ce9b498ab90172f437568c8275685dc51617e991216e38d515b3b5341760b964 SHA512 12dd50eeaae0aa5c2e3c89cb53cdb9989036759bd900312d3875eaba296646c2e42be31dc2b003cbc2401ccef8fbf8d2e460b9a604d7bece360f17f937d60cad
+DIST nDPI-4.8.tar.gz 39479237 BLAKE2B b2b30490a8688082cf41f364d4eeb24ccaaaf8e84e13963ad9fff2346888387b732bcd0c6485d7daba7ae131ea7ad58904f65d85ca7844da7d22bd120411ada0 SHA512 f76eb99a83262a6d148509c7ce457b9af35dce3657c8191405ba15999b25c323ee0bee2907b0a7e6ba6f12a63182fde839e0098a4e8e0f63999e600526f3036b
diff --git a/net-libs/nDPI/nDPI-4.8.ebuild b/net-libs/nDPI/nDPI-4.8.ebuild
new file mode 100644
index 000000000000..cca0c5c9ea00
--- /dev/null
+++ b/net-libs/nDPI/nDPI-4.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edo
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ntop/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0/$(ver_cut 1)"
+
+DEPEND="dev-libs/json-c:=
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # "local" here means "local to the system", and hence means
+ # system copy, not the bundled one.
+ econf --with-local-libgcrypt
+}
+
+src_test() {
+ pushd tests || die
+
+ edo ./do.sh
+ edo ./do-unit.sh
+
+ popd || die
+}
+
+src_install() {
+ default
+
+ # Makefile logic is broken in 4.8, let's wait a bit given history and
+ # go with hack for now.
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/usr/$(get_libdir)/pkgconfig || die
+ mv "${ED}"/usr/usr/* "${ED}"/usr || die
+ rm "${ED}/usr/$(get_libdir)"/lib${PN,,}.a || die
+ rm -rf "${ED}"/usr/usr || die
+}