summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-26 16:41:54 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-26 16:41:54 +0100
commitfe931693d93404eaf409a4f12ac81d4f6e2bf86a (patch)
treefbb70c9dffe426403b94aa0ba9035b28517fb823 /net-libs/zeromq
parentnet-libs/zeromq: fix automagic on dev-libs/libbsd (diff)
downloadgentoo-fe931693d93404eaf409a4f12ac81d4f6e2bf86a.tar.gz
gentoo-fe931693d93404eaf409a4f12ac81d4f6e2bf86a.tar.bz2
gentoo-fe931693d93404eaf409a4f12ac81d4f6e2bf86a.zip
net-libs/zeromq: fix NonexistentDeps on net-libs/openpgm
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/zeromq')
-rw-r--r--net-libs/zeromq/zeromq-4.3.3-r1.ebuild5
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r1.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/net-libs/zeromq/zeromq-4.3.3-r1.ebuild b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
index aacebe8becf4..da4a09e97c25 100644
--- a/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
@@ -18,8 +18,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
libbsd? ( dev-libs/libbsd:= )
- sodium? ( dev-libs/libsodium:= )
- pgm? ( ~net-libs/openpgm-5.2.122 )"
+ sodium? ( dev-libs/libsodium:= )"
DEPEND="${RDEPEND}
!elibc_Darwin? ( sys-apps/util-linux )
doc? (
@@ -39,12 +38,12 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-shared
+ --without-pgm
$(use_enable drafts)
$(use_enable libbsd)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)
- $(use_with pgm)
$(use_with doc docs)
)
econf "${myeconfargs[@]}"
diff --git a/net-libs/zeromq/zeromq-4.3.4-r1.ebuild b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
index a17c74cf70e3..9a32f20db6b1 100644
--- a/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
@@ -18,8 +18,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
libbsd? ( dev-libs/libbsd:= )
- sodium? ( dev-libs/libsodium:= )
- pgm? ( ~net-libs/openpgm-5.2.122 )"
+ sodium? ( dev-libs/libsodium:= )"
DEPEND="${RDEPEND}
!elibc_Darwin? ( sys-apps/util-linux )
doc? (
@@ -39,12 +38,12 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-shared
+ --without-pgm
$(use_enable drafts)
$(use_enable libbsd)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)
- $(use_with pgm)
$(use_with doc docs)
)
econf "${myeconfargs[@]}"