summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-08 08:03:23 +0100
committerSam James <sam@gentoo.org>2024-04-08 08:03:23 +0100
commit3284575fea1b242bb47eaab8854f17162b1d8614 (patch)
treec861dbce6ccdd0d62bb192d5057041d46a857466 /net-libs/zeromq
parentnet-libs/czmq: conditionally build tests (diff)
downloadgentoo-3284575fea1b242bb47eaab8854f17162b1d8614.tar.gz
gentoo-3284575fea1b242bb47eaab8854f17162b1d8614.tar.bz2
gentoo-3284575fea1b242bb47eaab8854f17162b1d8614.zip
net-libs/zeromq: force bash for now until upstream fixes land
One of the fixes is in an upstream project used for all their autotools bits. Closes: https://bugs.gentoo.org/923922 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/zeromq')
-rw-r--r--net-libs/zeromq/zeromq-4.3.3-r1.ebuild7
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r1.ebuild7
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r2.ebuild7
-rw-r--r--net-libs/zeromq/zeromq-4.3.5-r1.ebuild8
-rw-r--r--net-libs/zeromq/zeromq-4.3.5.ebuild7
5 files changed, 26 insertions, 10 deletions
diff --git a/net-libs/zeromq/zeromq-4.3.3-r1.ebuild b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
index f507ff1b89b5..87f3eeabceb6 100644
--- a/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -46,7 +46,10 @@ src_configure() {
$(use_with sodium libsodium)
$(use_with doc docs)
)
- econf "${myeconfargs[@]}"
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {
diff --git a/net-libs/zeromq/zeromq-4.3.4-r1.ebuild b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
index 7fdebcd85665..c18331194b3b 100644
--- a/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -46,7 +46,10 @@ src_configure() {
$(use_with sodium libsodium)
$(use_with doc docs)
)
- econf "${myeconfargs[@]}"
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {
diff --git a/net-libs/zeromq/zeromq-4.3.4-r2.ebuild b/net-libs/zeromq/zeromq-4.3.4-r2.ebuild
index f9a40343c196..e3d18dcd4cb1 100644
--- a/net-libs/zeromq/zeromq-4.3.4-r2.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -56,7 +56,10 @@ src_configure() {
$(use_with sodium libsodium)
$(use_with doc docs)
)
- econf "${myeconfargs[@]}"
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {
diff --git a/net-libs/zeromq/zeromq-4.3.5-r1.ebuild b/net-libs/zeromq/zeromq-4.3.5-r1.ebuild
index e42b438ca368..6108f439cba7 100644
--- a/net-libs/zeromq/zeromq-4.3.5-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -54,7 +54,11 @@ src_configure() {
$(use_with sodium libsodium)
$(use_with doc docs)
)
- econf "${myeconfargs[@]}"
+
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {
diff --git a/net-libs/zeromq/zeromq-4.3.5.ebuild b/net-libs/zeromq/zeromq-4.3.5.ebuild
index c894ce5dca79..09f7ce445d8f 100644
--- a/net-libs/zeromq/zeromq-4.3.5.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,7 +40,10 @@ src_configure() {
$(use_with sodium libsodium)
$(use_with doc docs)
)
- econf "${myeconfargs[@]}"
+ # Force bash for configure until the fixes for bug #923922 land in a release
+ # https://github.com/zeromq/zproject/pull/1336
+ # https://github.com/zeromq/libzmq/pull/4651
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {