summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/qmf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/qmf')
-rw-r--r--net-libs/qmf/Manifest1
-rw-r--r--net-libs/qmf/files/qmf-4.0.2-tests.patch13
-rw-r--r--net-libs/qmf/metadata.xml9
-rw-r--r--net-libs/qmf/qmf-4.0.3.ebuild108
4 files changed, 131 insertions, 0 deletions
diff --git a/net-libs/qmf/Manifest b/net-libs/qmf/Manifest
new file mode 100644
index 000000000000..a1e0e90ef920
--- /dev/null
+++ b/net-libs/qmf/Manifest
@@ -0,0 +1 @@
+DIST qmf-4.0.3.tar.gz 2099647 SHA256 0de3f27a49d5c7d67db3266ba62b61e260a850ea88420efb03db00502e45e39a SHA512 2df508ccc5d14bd1f0e68c2e07bded8b89c0c970302a130975c1ae3e49935ff46e77741a5c63580394c423fc56e526d3ac7738c740fc29f5d2eaec7fe2c8005d WHIRLPOOL 907315c32a900c60dd4b4a2122fef97454f5c922936b6c9ea269ec4c0d4d74ccea4f2d2248f348bb691057f4cbf36ddf11a2f3ab2192ff886db81873bcec60d3
diff --git a/net-libs/qmf/files/qmf-4.0.2-tests.patch b/net-libs/qmf/files/qmf-4.0.2-tests.patch
new file mode 100644
index 000000000000..38a7f4c7b714
--- /dev/null
+++ b/net-libs/qmf/files/qmf-4.0.2-tests.patch
@@ -0,0 +1,13 @@
+diff -Naur qmf-9999.orig/tests/tests.pri qmf-9999/tests/tests.pri
+--- qmf-9999.orig/tests/tests.pri 2013-04-13 12:05:32.323423194 -0700
++++ qmf-9999/tests/tests.pri 2013-04-13 12:09:25.068513480 -0700
+@@ -11,7 +11,8 @@
+ INCLUDEPATH += . $$QMFPATH $$QMFPATH/support
+ LIBS += -L$$QMFPATH/build
+ macx:LIBS += -F$$QMFPATH/build
+-QMAKE_LFLAGS += -Wl,-rpath,$$QMFPATH
++QMAKE_LFLAGS += -Wl,-rpath,\\\$$ORIGIN/$$QMFPATH/build
+
+ include(../common.pri)
+
++DESTDIR =
diff --git a/net-libs/qmf/metadata.xml b/net-libs/qmf/metadata.xml
new file mode 100644
index 000000000000..4fd5a5f7ed23
--- /dev/null
+++ b/net-libs/qmf/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+ <email>pesa@gentoo.org</email>
+ <name>Davide Pesavento</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-libs/qmf/qmf-4.0.3.ebuild b/net-libs/qmf/qmf-4.0.3.ebuild
new file mode 100644
index 000000000000..eb5e32e7eefd
--- /dev/null
+++ b/net-libs/qmf/qmf-4.0.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=(
+ "git://code.qt.io/qt-labs/messagingframework.git"
+ "https://code.qt.io/git/qt-labs/messagingframework.git"
+ )
+else
+ SRC_URI="http://dev.gentoo.org/~pesa/distfiles/${P}.tar.gz"
+ S=${WORKDIR}/qt-labs-messagingframework
+fi
+
+DESCRIPTION="The Qt Messaging Framework"
+HOMEPAGE="https://code.qt.io/cgit/qt-labs/messagingframework.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="debug doc examples icu test zlib"
+
+RDEPEND="
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtgui-4.8:4
+ >=dev-qt/qtsql-4.8:4
+ examples? ( >=dev-qt/qtwebkit-4.8:4 )
+ icu? ( dev-libs/icu:= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-qt/qttest-4.8:4 )
+"
+
+DOCS=( CHANGES )
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.2-tests.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i -e '/SUBDIRS.*=/s/benchmarks//' messagingframework.pro || die
+
+ if ! use examples; then
+ sed -i -e '/SUBDIRS.*=/s/examples//' messagingframework.pro || die
+ fi
+ if ! use test; then
+ sed -i -e '/SUBDIRS.*=/s/tests//' messagingframework.pro || die
+ fi
+
+ # disable automagic deps
+ if ! use icu; then
+ sed -i -e 's/packagesExist(icu-uc)/false:&/' \
+ src/libraries/qmfclient/qmfclient.pro || die
+ fi
+ if ! use zlib; then
+ sed -i -e 's/packagesExist(zlib)/false:&/' \
+ src/plugins/messageservices/imap/imap.pro || die
+ fi
+
+ # fix libdir
+ find "${S}" -name '*.pro' -type f -print0 | xargs -0 \
+ sed -i -re "s:/lib(/|$):/$(get_libdir)\1:" || die
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ src/libraries/qmfclient/support/qmailnamespace.cpp || die
+}
+
+src_configure() {
+ eqmake4 QMF_INSTALL_ROOT="${EPREFIX}/usr"
+}
+
+src_test() {
+ cd "${S}"/tests
+
+ export QMF_DATA=${T}
+ local fail=false test=
+ for test in tst_*; do
+ # skip test that requires messageserver to be running
+ [[ ${test} == tst_qmailstorageaction ]] && continue
+
+ if ! LC_ALL=C ./${test}/${test}; then
+ eerror "${test#tst_} test failed!"
+ fail=true
+ fi
+ echo
+ done
+
+ ${fail} && die "some tests have failed!"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use doc; then
+ emake docs
+
+ dodoc -r doc/html
+ dodoc doc/html/qmf.qch
+ docompress -x /usr/share/doc/${PF}/qmf.qch
+ fi
+}