summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-14 13:43:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-14 15:35:40 +0200
commit3b471745caf9ce9034e018f99804e5d55ee34921 (patch)
tree6e3bc032d6ad9ae4798fd25a40bc51107622fe68 /net-libs/ntirpc
parentapp-arch/rar: Bump to v5.5.0 from 2017-08-11 (diff)
downloadgentoo-3b471745caf9ce9034e018f99804e5d55ee34921.tar.gz
gentoo-3b471745caf9ce9034e018f99804e5d55ee34921.tar.bz2
gentoo-3b471745caf9ce9034e018f99804e5d55ee34921.zip
net-libs/ntirpc: Bump to version 1.5.2
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-1.5.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index 8b2bada00f3c..8c45a22f94f2 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1 +1,2 @@
DIST ntirpc-1.4.1.tar.gz 446025 SHA256 0e0a8a33f49ae91bccd73cfe7cc0ba33641df3cb9ed589dd5d81140a9d8838d0 SHA512 49a27dbd68b3e292437392acf2c010cc968b4d29b82b6e1a84e6c81a0c3979d3b38338212b391294b543ccd321073a33b16d7231ab68d797ead414d1b919137c WHIRLPOOL 01a287654bacf6a1647bb0847197ea7a427cfe6bdb6c379846ab9ca1dc872173edb8c899fe11511155fcddbafec24e4a6536607d4ce31c0b0476c872c8d41176
+DIST ntirpc-1.5.2.tar.gz 433706 SHA256 94751ea3a93c880516fc06d2805399440d92e348b6b78baf35436cda8f7d73d2 SHA512 5bbc48ab5bf2aba7e4c473a6faf586c1aef27a2009bf92082495456c436c707dfdcfc5e16a56c3e31ba3fb68afc3d2d47e8d27ed03be5c0be44e22e24a0cb68e WHIRLPOOL 4e00a07b9d905a1d622fefb3040a3868bf776aaabbdb79406f6569a94f4387716f76f110d21d3bc22693e0cb747d2082e0ba3321ccbfa6146155b295612a3bb6
diff --git a/net-libs/ntirpc/ntirpc-1.5.2.ebuild b/net-libs/ntirpc/ntirpc-1.5.2.ebuild
new file mode 100644
index 000000000000..0f07315803a4
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/linuxbox2/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_PRC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}