summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-08-22 16:21:19 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-08-22 16:21:19 -0500
commit56e0a3c32743e5d2ae9e6380cd0ce5aaa9ac9977 (patch)
treecfcc71d70ad64e15550e12d91693ffd410aa7c32 /net-libs/nodejs
parentgui-wm/gamescope: Bump Wayland dependency for bundled wlroots (diff)
downloadgentoo-56e0a3c32743e5d2ae9e6380cd0ce5aaa9ac9977.tar.gz
gentoo-56e0a3c32743e5d2ae9e6380cd0ce5aaa9ac9977.tar.bz2
gentoo-56e0a3c32743e5d2ae9e6380cd0ce5aaa9ac9977.zip
net-libs/nodejs: add 20.17.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/Manifest1
-rw-r--r--net-libs/nodejs/nodejs-20.17.0.ebuild266
2 files changed, 267 insertions, 0 deletions
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index 28f6eea9d754..0f6fdf515a02 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -1,5 +1,6 @@
DIST node-v18.20.4.tar.xz 40445740 BLAKE2B 0675f2aba1d9a9cd9aeb665ecb3a0f61b9caf39daeb6154941f84b9c423caa7a658c14b8c2c5e12d94424b2470748ec7fad28ecb10390d37f92eb7e50f8adc26 SHA512 1ccef99ebee3906f5bad3c1582f9551ced9bed15e6a047d59d1a23c6110004fb46ea4bebcf9899748c64109f78788d7365ee956444e645eaf397dabbcddda21e
DIST node-v20.15.1.tar.xz 41880412 BLAKE2B f113856db03a3306d50a659e21d11f585e9e78b85ce7ad9926cc778837f905c618ac762faf56e03caaa862ab0a38c5f34770cd2bfb0854d79650ee9d9b9e2bfe SHA512 2a2935490c4c629f47cc67819094904a1b91eaf0b75cbb8ebe92f5eb34b0929230932fa456bf1bec00213155ea8b6337b2e02e946fc18606543c8c71082615b9
DIST node-v20.16.0.tar.xz 41822608 BLAKE2B 90421b9bf5fad96fadee3eb6fc12461aa6a3456a5266a03f1286f977429af6992e5b1c81a72faa54b3349d46e93881fbfad8970bdebe56afde16b17a1a59dd26 SHA512 494ac16904ecb9f799789f190b869b7509bc66e99713d72723d2bf5051a8a5ca57a4f7303c732aa1fd121cff0defd238be4f656cb4d4e81cc7416b63d9c8677d
+DIST node-v20.17.0.tar.xz 41751520 BLAKE2B 157cf4c3326fcd2f1324c0898018c88327df05c717acfa8d96728e1ebf378ea04e46da56b93e89041a49b5ee4b7e6070373401a2bc2e9163eec3b0dffb6ff4d3 SHA512 3f21c9b5b292143d25a9d51e24d8f9b366429872b3d905d705fb2293e4f4b11e8861650535425d498b999974971a8dec7bf9f9c398af03170caa84bdc63b94da
DIST node-v22.4.1.tar.xz 46125104 BLAKE2B 7e54a7e01f821d752abbec03212c5be838b2e12fdb10c50cfe05b0ec25ddbe71eaa3187ba25d99efb258ab14d31927216e6816aacdfa29efdb1dc70a06e9b135 SHA512 840423e9738cad9f6024e9b51b683893eab16487ba18183251a189b5d4acf9b4168e9245623092705b014bff2058174127d5d7ecb31c1a8b324961074cb8ca54
DIST node-v22.6.0.tar.xz 46900628 BLAKE2B 52d566fcc25c370dd2cddbc21f4f9a9d7293b454b832eaaece979fa25232fef59270ba980ebfe6b8ac2424c733ef3ec33a7e7f689b818a30071ec9d3854bc553 SHA512 31a1ad99bf131917b45ec353929525686d22ed3eea1ea9f9498b5a43c0bf38b5f68885fc4a174f9d819a01745767a8b4e8d0577a7eec150456b4a102ddad639b
diff --git a/net-libs/nodejs/nodejs-20.17.0.ebuild b/net-libs/nodejs/nodejs-20.17.0.ebuild
new file mode 100644
index 000000000000..810d175eaacf
--- /dev/null
+++ b/net-libs/nodejs/nodejs-20.17.0.ebuild
@@ -0,0 +1,266 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CONFIG_CHECK="~ADVISE_SYSCALLS"
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nodejs/node"
+ SLOT="0"
+else
+ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+ SLOT="0/$(ver_cut 1)"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
+ S="${WORKDIR}/node-v${PV}"
+fi
+
+IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
+REQUIRED_USE="inspector? ( icu ssl )
+ npm? ( ssl )
+ system-icu? ( icu )
+ system-ssl? ( ssl )
+ x86? ( cpu_flags_x86_sse2 )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-arch/brotli-1.0.9:=
+ >=dev-libs/libuv-1.46.0:=
+ >=net-dns/c-ares-1.18.1:=
+ >=net-libs/nghttp2-1.41.0:=
+ >=net-libs/ngtcp2-1.1.0:=
+ sys-libs/zlib
+ corepack? ( !sys-apps/yarn )
+ system-icu? ( >=dev-libs/icu-73:= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ sys-devel/gcc:*"
+BDEPEND="${PYTHON_DEPS}
+ app-alternatives/ninja
+ sys-apps/coreutils
+ virtual/pkgconfig
+ test? ( net-misc/curl )
+ pax-kernel? ( sys-apps/elfix )"
+DEPEND="${RDEPEND}"
+
+# These are measured on a loong machine with -ggdb on, and only checked
+# if debugging flags are present in CFLAGS.
+#
+# The final link consumed a little more than 7GiB alone, so 8GiB is the lower
+# limit for memory usage. Disk usage was 19.1GiB for the build directory and
+# 1.2GiB for the installed image, so we leave some room for architectures with
+# fatter binaries and set the disk requirement to 22GiB.
+CHECKREQS_MEMORY="8G"
+CHECKREQS_DISK_BUILD="22G"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space and memory to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ tc-export AR CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ sed -i -e "/'-O3'/d" common.gypi node.gypi || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ # We need to disable mprotect on two files when it builds Bug 694100.
+ use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-20.6.0-paxmarking.patch )
+
+ default
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ # LTO compiler flags are handled by configure.py itself
+ filter-lto
+ # nodejs unconditionally links to libatomic #869992
+ # specifically it requires __atomic_is_lock_free which
+ # is not yet implemented by sys-libs/compiler-rt (see
+ # https://reviews.llvm.org/D85044?id=287068), therefore
+ # we depend on gcc and force using libgcc as the support lib
+ tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
+
+ local myconf=(
+ --ninja
+ --shared-brotli
+ --shared-cares
+ --shared-libuv
+ --shared-nghttp2
+ --shared-ngtcp2
+ --shared-zlib
+ )
+ use debug && myconf+=( --debug )
+ use lto && myconf+=( --enable-lto )
+ if use system-icu; then
+ myconf+=( --with-intl=system-icu )
+ elif use icu; then
+ myconf+=( --with-intl=full-icu )
+ else
+ myconf+=( --with-intl=none )
+ fi
+ use corepack || myconf+=( --without-corepack )
+ use inspector || myconf+=( --without-inspector )
+ use npm || myconf+=( --without-npm )
+ use snapshot || myconf+=( --without-node-snapshot )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
+
+ local myarch=""
+ case "${ARCH}:${ABI}" in
+ *:amd64) myarch="x64";;
+ *:arm) myarch="arm";;
+ *:arm64) myarch="arm64";;
+ loong:lp64*) myarch="loong64";;
+ riscv:lp64*) myarch="riscv64";;
+ *:ppc64) myarch="ppc64";;
+ *:x32) myarch="x32";;
+ *:x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${EPYTHON}" configure.py \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ export NINJA_ARGS=" $(get_NINJAOPTS) "
+ emake -Onone
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ default
+
+ pax-mark -m "${ED}"/usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ docinto html
+ dodoc -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ keepdir /etc/npm
+ echo "NPM_CONFIG_GLOBALCONFIG=${EPREFIX}/etc/npm/npmrc" > "${T}"/50npm
+ doenvd "${T}"/50npm
+
+ # Install bash completion for `npm`
+ local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+
+ use corepack &&
+ "${D}"/usr/bin/corepack enable --install-directory "${D}"/usr/bin
+
+ mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
+}
+
+src_test() {
+ local drop_tests=(
+ test/parallel/test-dns.js
+ test/parallel/test-dns-resolveany-bad-ancount.js
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-read-stream.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-fs-watch-recursive-add-file.js
+ test/parallel/test-process-euid-egid.js
+ test/parallel/test-process-get-builtin.mjs
+ test/parallel/test-process-initgroups.js
+ test/parallel/test-process-setgroups.js
+ test/parallel/test-process-uid-gid.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ use inspector || drop_tests+=( test/sequential/test-watch-mode.mjs )
+ [[ "$(nice)" -gt 10 ]] && drop_tests+=( "test/parallel/test-os.js" )
+ rm -f "${drop_tests[@]}" || die "disabling tests failed"
+
+ out/${BUILDTYPE}/cctest || die
+ "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ if use npm; then
+ ewarn "remember to run: source /etc/profile if you plan to use nodejs"
+ ewarn " in your current shell"
+ fi
+}