summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-04-05 11:24:43 -0400
committerCraig Andrews <candrews@gentoo.org>2024-04-05 11:26:29 -0400
commitb3c7d3a5d415467c36a739d4dea24f59f8c30c9f (patch)
tree34a23cf474daadc54765fb743d2376bdcc37ecc1 /net-libs/nghttp3
parentdev-python/trove-classifiers: Stabilize 2024.3.25 ALLARCHES, #928649 (diff)
downloadgentoo-b3c7d3a5d415467c36a739d4dea24f59f8c30c9f.tar.gz
gentoo-b3c7d3a5d415467c36a739d4dea24f59f8c30c9f.tar.bz2
gentoo-b3c7d3a5d415467c36a739d4dea24f59f8c30c9f.zip
net-libs/nghttp3: remove unused cunit dependency
Bug: https://bugs.gentoo.org/924750 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/nghttp3-1.2.0-r2.ebuild37
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild4
2 files changed, 38 insertions, 3 deletions
diff --git a/net-libs/nghttp3/nghttp3-1.2.0-r2.ebuild b/net-libs/nghttp3/nghttp3-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..6715be902969
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.2.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 3a8480492ead..6715be902969 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -18,12 +18,10 @@ HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
LICENSE="MIT"
SLOT="0/0"
-IUSE="static-libs test"
+IUSE="static-libs"
BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
RDEPEND=""
-RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=(