summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-04 09:54:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-04 10:07:12 +0200
commit9c70e226b7eddf2bed40f711781fc898af35e86e (patch)
tree21cca0214aac6733f1f7284f32b6160ed546dd83 /net-libs/nghttp2
parentnet-libs/nghttp2: Removed old. (diff)
downloadgentoo-9c70e226b7eddf2bed40f711781fc898af35e86e.tar.gz
gentoo-9c70e226b7eddf2bed40f711781fc898af35e86e.tar.bz2
gentoo-9c70e226b7eddf2bed40f711781fc898af35e86e.zip
net-libs/nghttp2: Bumped live ebuild to EAPI-6.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index 776f0f6311a0..2e6405711fca 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -4,13 +4,13 @@
# TODO: Add python support.
-EAPI="5"
+EAPI=6
inherit multilib-minimal
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
- inherit git-2
+ inherit autotools git-r3
else
SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -38,6 +38,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \