summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-04 14:06:12 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-04 14:47:08 +0000
commitcd5b82cfb6c92803d41edee88eb1f21817e19097 (patch)
tree171e4367443612b0893e5617a3af293c291250f5 /net-libs/libhtp
parentmail-mta/protonmail-bridge: remove old (diff)
downloadgentoo-cd5b82cfb6c92803d41edee88eb1f21817e19097.tar.gz
gentoo-cd5b82cfb6c92803d41edee88eb1f21817e19097.tar.bz2
gentoo-cd5b82cfb6c92803d41edee88eb1f21817e19097.zip
net-libs/libhtp: bump to 0.5.37
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.37.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index 944f736bf62a..eb915c57cc2f 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1,2 +1,3 @@
DIST libhtp-0.5.35.tar.gz 496852 BLAKE2B 21ee020f94ea351f408eb3d0d2f99b01f054341a390c9cc42c44a1f2237a1fe965e12797ecc04cf9a519e34fcf495fae4b4119bca6c38ef1d1fa0a9d35c243fe SHA512 d88a8b5f93759a348d0cb039dd95c5504b09b6ff577138cebbaaccf06a6e7ab682e8b61d904e005af67ea4887492d949cdb466d1cbbd9b970a94a30e8b26564e
DIST libhtp-0.5.36.tar.gz 496866 BLAKE2B 216ce8833d32659bb189a0f3592c06e0ef96e06f54eaeee0b0ee1714936fe45879db69c557327f7d2998235531d066bef83f1c6047c7e01fd23c7fa54f362dae SHA512 8243c75d8d397abda14aae9816ee850023c5e3dae32b4ca4479d0a15cf575b6fd5a69a037f03853f5ab0c10ee027bd20119640725332fdb7154b95aa5290c6ee
+DIST libhtp-0.5.37.tar.gz 497609 BLAKE2B 74dfe93495781fb918b4703c5f9a9a37abde3da8833b8b17c183200cc04d5abb20b1dd28acfe9cc5eefce486b5e29c381077d75fe6a0e1bd584ceb3a1d19d93f SHA512 e2a16862703e2541cecb841bc93fe1ea72f580fb5ed2c54583072bee4843b41510dae53a0e76105d2ee2e06ea5e3410c280296a98fbf8e24f7cf2705356bb9e2
diff --git a/net-libs/libhtp/libhtp-0.5.37.ebuild b/net-libs/libhtp/libhtp-0.5.37.ebuild
new file mode 100644
index 000000000000..52f8e32728c6
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.37.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}