summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-06 22:09:34 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-06 22:10:24 +0100
commit728415ef3b48f9e26cf09257f707d595f4aa7172 (patch)
treee7897a8e08b894500c90c374f4be98ff5f14443b /net-libs/libhtp
parentsys-process/parallel: Stabilize 20201022 arm64, #758824 (diff)
downloadgentoo-728415ef3b48f9e26cf09257f707d595f4aa7172.tar.gz
gentoo-728415ef3b48f9e26cf09257f707d595f4aa7172.tar.bz2
gentoo-728415ef3b48f9e26cf09257f707d595f4aa7172.zip
net-libs/libhtp: bump to 0.5.36
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.36.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index 012f450e37d7..944f736bf62a 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST libhtp-0.5.35.tar.gz 496852 BLAKE2B 21ee020f94ea351f408eb3d0d2f99b01f054341a390c9cc42c44a1f2237a1fe965e12797ecc04cf9a519e34fcf495fae4b4119bca6c38ef1d1fa0a9d35c243fe SHA512 d88a8b5f93759a348d0cb039dd95c5504b09b6ff577138cebbaaccf06a6e7ab682e8b61d904e005af67ea4887492d949cdb466d1cbbd9b970a94a30e8b26564e
+DIST libhtp-0.5.36.tar.gz 496866 BLAKE2B 216ce8833d32659bb189a0f3592c06e0ef96e06f54eaeee0b0ee1714936fe45879db69c557327f7d2998235531d066bef83f1c6047c7e01fd23c7fa54f362dae SHA512 8243c75d8d397abda14aae9816ee850023c5e3dae32b4ca4479d0a15cf575b6fd5a69a037f03853f5ab0c10ee027bd20119640725332fdb7154b95aa5290c6ee
diff --git a/net-libs/libhtp/libhtp-0.5.36.ebuild b/net-libs/libhtp/libhtp-0.5.36.ebuild
new file mode 100644
index 000000000000..4c0e8229142d
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.36.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}