summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-02-16 18:02:25 +0800
committerYixun Lan <dlan@gentoo.org>2021-02-16 18:08:05 +0800
commitc919d3125b271c8827f27aa81a1b9dce9dd7ff24 (patch)
treed28e7e92fee5300b88e175ad6239fa6b9af9f572 /net-libs/libcork/libcork-0.15.0-r2.ebuild
parentmedia-fonts/intlfonts: Version bump to 1.4.1 (diff)
downloadgentoo-c919d3125b271c8827f27aa81a1b9dce9dd7ff24.tar.gz
gentoo-c919d3125b271c8827f27aa81a1b9dce9dd7ff24.tar.bz2
gentoo-c919d3125b271c8827f27aa81a1b9dce9dd7ff24.zip
net-libs/libcork: drop building docs/old
drop building the doc due to sphinx error for now Cloese: https://bugs.gentoo.org/726926 Cloese: https://bugs.gentoo.org/734912 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-libs/libcork/libcork-0.15.0-r2.ebuild')
-rw-r--r--net-libs/libcork/libcork-0.15.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libcork/libcork-0.15.0-r2.ebuild b/net-libs/libcork/libcork-0.15.0-r2.ebuild
new file mode 100644
index 000000000000..fe49522a5e98
--- /dev/null
+++ b/net-libs/libcork/libcork-0.15.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A simple, easily embeddable cross-platform C library"
+HOMEPAGE="https://github.com/dcreager/libcork"
+SRC_URI="https://github.com/dcreager/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/check"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-git.patch"
+ "${FILESDIR}/${P}-version.patch"
+)
+
+src_prepare() {
+ if ! [ -e "${S}"/RELEASE-VERSION ] ; then
+ echo ${PV} > "${S}"/RELEASE-VERSION || die
+ fi
+ sed -i -e "s/-Werror/-Wextra/" \
+ -e "/docs\/old/d" \
+ CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC=$(usex static-libs)
+ )
+ cmake_src_configure
+}