summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-12-11 15:38:29 +0200
committerMart Raudsepp <leio@gentoo.org>2021-12-11 19:35:51 +0200
commit413edd0f9bfa89cab79a63934c7a3db3c1fb2b02 (patch)
treefbdc4005717fc84d5f7792a8022ca0e536d29c41 /net-libs/glib-networking
parentgames-server/minecraft-server: drop 1.16.5 (diff)
downloadgentoo-413edd0f9bfa89cab79a63934c7a3db3c1fb2b02.tar.gz
gentoo-413edd0f9bfa89cab79a63934c7a3db3c1fb2b02.tar.bz2
gentoo-413edd0f9bfa89cab79a63934c7a3db3c1fb2b02.zip
net-libs/glib-networking: bump to 2.70.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.70.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 7334d2f06e40..406f1a548387 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,3 +1,4 @@
DIST glib-networking-2.68.1.tar.xz 237876 BLAKE2B 11d982a3d65ae5793a3b6c30cf31737ede5879aa3747416253bacc34d62a1ada944a718223300d63a5b37615492929e63c1c0cad6ef34775ee95e49f6769dc04 SHA512 da38b64e6709c864e1c6a60989d86439e0afb1dbf7b7f60a67f58cf430ae354ef9fe7465e74790b0c2827d2f1c39a250db4372d98fab6ab8d73946a7f51e3b22
DIST glib-networking-2.68.2.tar.xz 239040 BLAKE2B 2b65a63205d3071d05898ca869ae117c9b9fd548b19d9a1c82869a1eb54b77113f8908cd32108f4ca851cc0975ed34c16df04906b5b3c1f9a9a03574187ba929 SHA512 5c2d485332ff1b5a4d0f257b4e7a371b0bfe899b98ee4157845e5f5d3f10cf6f2df891407396edb6955420064dbaa57a5dc3c62c6392881cff05332db925d32d
DIST glib-networking-2.70.0.tar.xz 259808 BLAKE2B ebd423e9f93fc362cb6cece503de8f579c5c6de460e50f073107017ec0dc35cdd2f38fb780651dc7b68dd833500052c83bfba08e6c4b69c9aca1955f9aa7c7c2 SHA512 c9f8126e3466470ad8e1d588d56b843a4fa4738619a795e6772d95282c54a8356a916a3b0a0b6994606d8a6841ecb0637230f14575ed95ea68bff8f3f81aea71
+DIST glib-networking-2.70.1.tar.xz 261312 BLAKE2B bd0fb33e1ad359b36f78c8003ceb15290a9403d978400573ec7caabc44851f83f080d651085b85f7a5836a39c12c499222d8f9ad5bde51e5b24f6344332be1f7 SHA512 a06b4df4481f95193f9ed4be6d39bbe9ecaf4de8e11a48750f7110d4cfa71aa56b7ec5b36af70b7128150447f1a39ce3aeadf71e2ac516f61708f1212f8f855d
diff --git a/net-libs/glib-networking/glib-networking-2.70.1.ebuild b/net-libs/glib-networking/glib-networking-2.70.1.ebuild
new file mode 100644
index 000000000000..860454cb0242
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.70.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.69.0:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.2:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ xdg_src_prepare
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tls\/tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}