summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 14:44:13 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 15:42:24 -0400
commit55cd5e095b56c4ac9382ed52b175244a034d04cb (patch)
tree313937ab6112c79700cdd2158f124720292cf9c6 /net-libs/dleyna-core
parentapp-portage/gs-elpa: Generate ebuilds for EAPI 7 (diff)
downloadgentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.tar.gz
gentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.tar.bz2
gentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.zip
net-libs/dleyna-core: Version bump to 0.7.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/dleyna-core')
-rw-r--r--net-libs/dleyna-core/Manifest1
-rw-r--r--net-libs/dleyna-core/dleyna-core-0.7.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/dleyna-core/Manifest b/net-libs/dleyna-core/Manifest
index adbf9ad1c719..5165a6882915 100644
--- a/net-libs/dleyna-core/Manifest
+++ b/net-libs/dleyna-core/Manifest
@@ -1 +1,2 @@
DIST dleyna-core-0.6.0.tar.gz 30821 BLAKE2B f97ef825ef28efd58877487074c0146f8c8425b000537a2281ab44465829030ba9b837f95ad16b56044837a3e571a0ce54a8126ddafc2dda551dbf1d8b11a79e SHA512 cda3f3ee2bea860b06447ab79d8ca62a29c8d26215774c44adb05e57316b95acd4df6ee4ecdd731574b6da5b3aef1c08977a649288004a62a88af38a83157b57
+DIST dleyna-core-0.7.0.tar.gz 28354 BLAKE2B cfc21da2be908701ffe87f653ddbb3e8241f3842031987de9a0615ccc5dcd4f2180aaf9caaf981c6421d9cbfdc4cecb359998988f13f48ac5a5696bf56d7ae79 SHA512 02509d2fc386bc1d7f9295df7a12315a664a9dc4cced871da193dc79e15c3291ad4497cd18c655a7eb3e4d865a6448526c6abc1df2dc086cb7fc94f44c09b7f0
diff --git a/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
new file mode 100644
index 000000000000..119dfa74760a
--- /dev/null
+++ b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="utility library for higher level dLeyna libraries"
+HOMEPAGE="https://github.com/phako/dleyna-core"
+SRC_URI="https://github.com/phako/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/5" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gupnp-1.2.0:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"