summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ii')
-rw-r--r--net-irc/ii/Manifest2
-rw-r--r--net-irc/ii/ii-1.6.ebuild40
-rw-r--r--net-irc/ii/ii-1.7.ebuild40
-rw-r--r--net-irc/ii/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/net-irc/ii/Manifest b/net-irc/ii/Manifest
new file mode 100644
index 000000000000..4e405e097864
--- /dev/null
+++ b/net-irc/ii/Manifest
@@ -0,0 +1,2 @@
+DIST ii-1.6.tar.gz 9970 SHA256 794fa639b253b4b332fa80e76cde782d9dae021dfaf35a207334c553d962cc29 SHA512 54e9adc11d06601c6933c3f6310dacbc66bd5b4e9cf469cc4866fda79d838b1dcd826ea9fc234ba6c76e22d2512283ad2a875986f7965f483c6be9f91dddf19d WHIRLPOOL 9c2f8d15ecc9efb96b87387df626497d2a6fecfd1833c9dbb799f2caf04e0d905a0b40d90d515554d529ade6af0d15393d326736188c93ce14d24ab648b72a1c
+DIST ii-1.7.tar.gz 10174 SHA256 3a72ac6606d5560b625c062c71f135820e2214fed098e6d624fc40632dc7cc9c SHA512 1fa744bc9b4291b5c6c56e023d982aad59001137db6c7682284a2d63e649a32d558adbb85ae3407e312ae5436852b4278c2c522d4ef03f47cf54ea3a1f13ca90 WHIRLPOOL 6aa7c43f7d9beca03724f98e2110ba4d2430943905d9c0a8cd28a9f8aba8d673af7eaaaa0c1b84028397fb566201581d8731e3387bcede589dfefb1f518953bc
diff --git a/net-irc/ii/ii-1.6.ebuild b/net-irc/ii/ii-1.6.ebuild
new file mode 100644
index 000000000000..216bb3abd42f
--- /dev/null
+++ b/net-irc/ii/ii-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="http://tools.suckless.org/ii/"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -g -O0/CFLAGS += /" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e /^LIBS/d \
+ config.mk || die "sed failed to fix {C,LD}FLAGS"
+
+ ht_fix_file query.sh
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin ii
+ newbin query.sh ii-query
+ dodoc CHANGES FAQ README
+ doman *.1
+}
diff --git a/net-irc/ii/ii-1.7.ebuild b/net-irc/ii/ii-1.7.ebuild
new file mode 100644
index 000000000000..a9b1b8ca1efc
--- /dev/null
+++ b/net-irc/ii/ii-1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="http://tools.suckless.org/ii/"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -g -O0/CFLAGS += /" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e /^LIBS/d \
+ config.mk || die "sed failed to fix {C,LD}FLAGS"
+
+ # enable verbose build
+ sed -i 's/@${CC}/${CC}/' Makefile || die
+
+ ht_fix_file query.sh
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ newbin query.sh ii-query
+ dodoc CHANGES FAQ README
+ doman *.1
+}
diff --git a/net-irc/ii/metadata.xml b/net-irc/ii/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ii/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>