summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-04-03 00:30:16 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-04-03 00:35:04 +0200
commit47abc08518a8905bab98cfdc4eb325edda2c1d8c (patch)
tree215dca983d3ea445d4d3bbb351cae9a615f26762 /net-irc/eggdrop
parentdev-python/spyder-kernels: Bump to 2.0.1 (diff)
downloadgentoo-47abc08518a8905bab98cfdc4eb325edda2c1d8c.tar.gz
gentoo-47abc08518a8905bab98cfdc4eb325edda2c1d8c.tar.bz2
gentoo-47abc08518a8905bab98cfdc4eb325edda2c1d8c.zip
net-irc/eggdrop: add 1.9.0, fixes build with USE=static
Closes: https://bugs.gentoo.org/774333 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/Manifest1
-rw-r--r--net-irc/eggdrop/eggdrop-1.9.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index e6a4928422b7..5c7f443037ad 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,2 +1,3 @@
DIST eggdrop-1.8.3.tar.gz 1756536 BLAKE2B c2693bc383e1d857fe784d54f34479e73902064196021788ddf21f0bb2910977c643d820d2f6b640bb459b2acbfad8158fc0b29b4d76c588dfd76fee09a6fa25 SHA512 ad3b93d18aaa05d0eb00f1089b68d1f077f316042e64fff511ad1bbac06d35105adcb503490faaac4c9fe720dd45a9f350115b6c5d0f41fe198f228213a7a3a3
DIST eggdrop-1.8.4.tar.gz 1784738 BLAKE2B a86cdc681ebd9c779b7da20f80ff312e4fc848e0cb0a0b9fa34941c91e1b89db1430126e3d0b94c7b4346c0bde099a6ddd343270943570744c46fc4ddd451540 SHA512 d08af09dc83045bf89eae957e7817591f16456f83ba3efe6b361fd421a3d4068348543275c26b27b006f09f06344c04cdf58ee4231f1aee0e7537ec39bc24b49
+DIST eggdrop-1.9.0.tar.gz 2206230 BLAKE2B 1c6c5c77558323ae80b4f486f30d106b2f336c61c50adc10302657c2878a755b48d8286ba70f662b6be132ffd569de5eb269cfca1e6e42675b007de43ccf4746 SHA512 e78e220c8207361c6d7bda06be6d0094d747809ff8554fed2ce4a5fb63df1d87f8b82a98d4f0b98909042af8f6719f4a7bf548f864d3d6dfa8caa57b346d32dc
diff --git a/net-irc/eggdrop/eggdrop-1.9.0.ebuild b/net-irc/eggdrop/eggdrop-1.9.0.ebuild
new file mode 100644
index 000000000000..5d6de0a857df
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.9.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+MY_P="${PN}-${PV/_rc/rc}"
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ipv6 ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_configure() {
+ econf $(use_enable ssl tls) \
+ $(use_enable ipv6 ipv6)
+
+ emake config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ emake DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}