summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2022-11-30 01:12:54 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-12-02 14:48:26 -0800
commitfe4cfd2ba2efef2336196921b72952c966537e2f (patch)
treeb28bb547e0ede04b723493ab631910da18bc17e0 /net-im
parentnet-dns/djbdns: new revision increasing tinydns's softlimit. (diff)
downloadgentoo-fe4cfd2ba2efef2336196921b72952c966537e2f.tar.gz
gentoo-fe4cfd2ba2efef2336196921b72952c966537e2f.tar.bz2
gentoo-fe4cfd2ba2efef2336196921b72952c966537e2f.zip
net-im/telegram-desktop: Fix call issue
Fixes an issue regarding ABI incompatibility, that would cause the application to crash during calls. Closes: https://bugs.gentoo.org/866055 Thanks-to: Matteo Pacini <m+gentoo@matteopacini.me> Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/telegram-desktop-4.3.4-r1.ebuild (renamed from net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild b/net-im/telegram-desktop/telegram-desktop-4.3.4-r1.ebuild
index 2f1d55aaabb3..839dae189ee7 100644
--- a/net-im/telegram-desktop/telegram-desktop-4.3.4.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-4.3.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit xdg cmake python-any-r1 optfeature
+inherit xdg cmake python-any-r1 optfeature flag-o-matic
DESCRIPTION="Official desktop client for Telegram"
HOMEPAGE="https://desktop.telegram.org"
@@ -124,6 +124,11 @@ src_prepare() {
}
src_configure() {
+ # The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep
+ # the same state across both projects.
+ # See https://bugs.gentoo.org/866055
+ append-cppflags '-DNDEBUG'
+
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
-DQT_VERSION_MAJOR=$(usex qt6 6 5)