summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-22 22:58:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-22 22:59:17 +0200
commit205327edae93c40df284c9face7f0f848ef22c03 (patch)
tree9a86ff27c0533db7f1a94f2aee1075eeb2db27b8 /net-im
parentsys-fs/mp3fs: Add missing media-libs/flac[cxx] USEdep (diff)
downloadgentoo-205327edae93c40df284c9face7f0f848ef22c03.tar.gz
gentoo-205327edae93c40df284c9face7f0f848ef22c03.tar.bz2
gentoo-205327edae93c40df284c9face7f0f848ef22c03.zip
net-im/choqok: Try to fix build with clang-16
Closes: https://bugs.gentoo.org/871546 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/choqok/choqok-1.7.0-r1.ebuild1
-rw-r--r--net-im/choqok/files/choqok-1.7.0-fix-KCModule-warning.patch43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-im/choqok/choqok-1.7.0-r1.ebuild b/net-im/choqok/choqok-1.7.0-r1.ebuild
index 347ae3c26c3d..665a4a472330 100644
--- a/net-im/choqok/choqok-1.7.0-r1.ebuild
+++ b/net-im/choqok/choqok-1.7.0-r1.ebuild
@@ -60,6 +60,7 @@ PATCHES=(
"${WORKDIR}/${P}-choqokplugin.patch"
"${WORKDIR}/${P}-fix-layout-of-tweets.patch" # KDE-bug 424938
"${WORKDIR}/${P}-fix-partially-static-signatures.patch" # KDE-bug 417297
+ "${FILESDIR}/${P}-fix-KCModule-warning.patch" # bug 871546, git master
)
src_configure() {
diff --git a/net-im/choqok/files/choqok-1.7.0-fix-KCModule-warning.patch b/net-im/choqok/files/choqok-1.7.0-fix-KCModule-warning.patch
new file mode 100644
index 000000000000..26721514ca04
--- /dev/null
+++ b/net-im/choqok/files/choqok-1.7.0-fix-KCModule-warning.patch
@@ -0,0 +1,43 @@
+From 9c488d8f776b5e7462e8e57dc2b15db5fe28815a Mon Sep 17 00:00:00 2001
+From: Andrea Scarpino <scarpino@kde.org>
+Date: Sat, 8 Feb 2020 16:06:18 +0100
+Subject: [PATCH] Fix warning about KCModule::changed
+
+---
+ choqok/config/behavior/behaviorconfig.cpp | 4 ++--
+ choqok/config/plugins/choqokpluginconfig.cpp | 3 +--
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/choqok/config/behavior/behaviorconfig.cpp b/choqok/config/behavior/behaviorconfig.cpp
+index a25b0196..fb1d16b3 100644
+--- a/choqok/config/behavior/behaviorconfig.cpp
++++ b/choqok/config/behavior/behaviorconfig.cpp
+@@ -95,9 +95,9 @@ BehaviorConfig::BehaviorConfig(QWidget *parent, const QVariantList &args)
+ d->mBehaviorTabCtl->addTab(d->proxyModule, proxyInfo.moduleName());
+
+ connect(d->mPrfsShorten, (void (BehaviorConfig_Shorten::*)(bool))&BehaviorConfig_Shorten::changed,
+- this, (void (KCModule::*)())&KCModule::changed);
++ this, &BehaviorConfig::markAsChanged);
+ connect(d->proxyModule, (void (KCModuleProxy::*)(KCModuleProxy*))&KCModuleProxy::changed,
+- this, (void (KCModule::*)())&KCModule::changed);
++ this, &BehaviorConfig::markAsChanged);
+
+ load();
+
+diff --git a/choqok/config/plugins/choqokpluginconfig.cpp b/choqok/config/plugins/choqokpluginconfig.cpp
+index 1a5f4fc2..4f36d608 100644
+--- a/choqok/config/plugins/choqokpluginconfig.cpp
++++ b/choqok/config/plugins/choqokpluginconfig.cpp
+@@ -46,8 +46,7 @@ ChoqokPluginConfig::ChoqokPluginConfig(QWidget *parent, const QVariantList &args
+ mainLayout->setMargin(0);
+ mainLayout->addWidget(m_pluginSelector);
+
+- connect(m_pluginSelector, &KPluginSelector::changed, this,
+- (void (KCModule::*)())&KCModule::changed);
++ connect(m_pluginSelector, &KPluginSelector::changed, this, &ChoqokPluginConfig::markAsChanged);
+ connect(m_pluginSelector, &KPluginSelector::configCommitted,
+ this, &ChoqokPluginConfig::reparseConfiguration);
+
+--
+GitLab
+