summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-10 12:08:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-10 12:10:15 +0100
commit064bc7efcdbaa228401161c5f3a5588d2a3d54d3 (patch)
tree1bf18d85d84d55c3807fb54bb7d897cacd5f8b71 /net-im
parentsci-libs/libqalculate: Stabilize 3.22.0 arm64, #830765 (diff)
downloadgentoo-064bc7efcdbaa228401161c5f3a5588d2a3d54d3.tar.gz
gentoo-064bc7efcdbaa228401161c5f3a5588d2a3d54d3.tar.bz2
gentoo-064bc7efcdbaa228401161c5f3a5588d2a3d54d3.zip
net-im/rocketchat-desktop-bin: add version 3.7.5
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index d07093bcdb73..dd4d51514edc 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.4.x86_64.rpm 72045096 BLAKE2B a802cc5201f74061345bfcb7fa04ede24f945fd8ad1f15a24647f6f987c8f6473af6cfc858d742d54cce58219b0bc6e6f34f7d1c0827daa223166502793d01fb SHA512 817dd1fdaf6aa9d343b6557e613f691c158ae262fdb7b6d7029b64808c693f0b7db325be4815e6dff3b417f67484d14c543f370ca00339d6d4551af6fe5360f1
+DIST rocketchat-3.7.5.x86_64.rpm 72083048 BLAKE2B 136b0a1051d52b5a9c3c5d66eba8e0cde809bf5086bf6d0dbeb1dc319cbe73ff26c5d33f0a0e989b18c18f38406dedcad344f14ba532953679c7da53aebf4d74 SHA512 48fb9ce3602e7b3ebd2e049975941795cd00a1c89987b267988357af48bdaad958f2c1976c848a7be7e29f4726619531fbb6994cab927d39f13f50f182519818
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.5.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.5.ebuild
new file mode 100644
index 000000000000..4a153a7e3205
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}