summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorreagentoo <reagentoo@gmail.com>2018-01-03 23:40:53 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-04 11:40:11 +0100
commitb3c088124e0104412ea99defe4aa04f39788b154 (patch)
treec1589f7883f508f928eb1a63cbece83aa034ae2c /net-im/vacuum
parentdev-util/trinity: Drop old (diff)
downloadgentoo-b3c088124e0104412ea99defe4aa04f39788b154.tar.gz
gentoo-b3c088124e0104412ea99defe4aa04f39788b154.tar.bz2
gentoo-b3c088124e0104412ea99defe4aa04f39788b154.zip
net-im/vacuum: Switch live to Qt5-based master, fix cmake warning
- fix PLUGIN_adiummessagestyle, available only if NO_WEBKIT=OFF - append proxy in metadata.xml Closes: https://github.com/gentoo/gentoo/pull/6738
Diffstat (limited to 'net-im/vacuum')
-rw-r--r--net-im/vacuum/metadata.xml8
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild9
2 files changed, 13 insertions, 4 deletions
diff --git a/net-im/vacuum/metadata.xml b/net-im/vacuum/metadata.xml
index 3cc79d8c7880..7cef94a3a3ad 100644
--- a/net-im/vacuum/metadata.xml
+++ b/net-im/vacuum/metadata.xml
@@ -5,6 +5,14 @@
<email>maksbotan@gentoo.org</email>
<name>Maxim Koltsov</name>
</maintainer>
+ <maintainer type="person">
+ <email>reagentoo@gmail.com</email>
+ <name>Dmitry Baranov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="adiummessagestyle">Use UI styles created for Adium</flag>
<flag name="annotations">Enable adding comments to the contacts in the roster</flag>
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index 76ab422c67cf..56de1a0b3375 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-EGIT_BRANCH="dev_qt5"
EGIT_REPO_URI="https://github.com/Vacuum-IM/vacuum-im.git"
PLOCALES="de es pl ru uk"
inherit cmake-utils git-r3 l10n
@@ -14,9 +13,9 @@ HOMEPAGE="http://www.vacuum-im.org/"
LICENSE="GPL-3"
SLOT="0/37" # subslot = libvacuumutils soname version
KEYWORDS=""
-PLUGINS=( adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage recentcontacts registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries )
+PLUGINS=( annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage recentcontacts registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries )
SPELLCHECKER_BACKENDS="aspell +enchant hunspell"
-IUSE="${PLUGINS[@]/#/+} ${SPELLCHECKER_BACKENDS} +spell"
+IUSE="adiummessagestyle ${PLUGINS[@]/#/+} ${SPELLCHECKER_BACKENDS} +spell"
REQUIRED_USE="
annotations? ( privatestorage )
@@ -83,6 +82,8 @@ src_configure() {
-DPLUGIN_spellchecker=$(usex spell)
)
+ use adiummessagestyle && mycmakeargs+=( -DPLUGIN_adiummessagestyle=ON )
+
for x in ${PLUGINS[@]}; do
mycmakeargs+=( -DPLUGIN_${x}=$(usex $x) )
done