summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.bugzilla.2012@r123.de>2018-09-21 11:16:36 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-28 14:03:55 +0200
commite3f03539c55760f51731d92c0963c7de5183c1a0 (patch)
tree64bdd13bcdefdfa8e6f9100d9e3c83c7eb3edfd8 /net-im/signal-desktop-bin
parentmedia-libs/dav1d: Add new package (diff)
downloadgentoo-e3f03539c55760f51731d92c0963c7de5183c1a0.tar.gz
gentoo-e3f03539c55760f51731d92c0963c7de5183c1a0.tar.bz2
gentoo-e3f03539c55760f51731d92c0963c7de5183c1a0.zip
net-im/signal-desktop-bin: new version 1.16.2
Signed-off-by: Robert Siebeck <gentoo.bugzilla.2012@r123.de> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im/signal-desktop-bin')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.16.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index 96a117eee78a..3c80d0103c98 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.16.1_amd64.deb 70133768 BLAKE2B b647b7ee63422650fc1807469acfce04d901e4bcc1e4157ba528227afbc55376efbf48ad12fd21e671c9630366ed65c781f508f9f704adad096141abe3ee4aa2 SHA512 8d26b71f5b4f7c2e003dbbb8c83ffd7dbce416a65456b4fec4d03023e526175a574a690f2fbe2d82d5fcb9273abc8be2e2f98711c0f845b68779fe8079b18ce5
+DIST signal-desktop_1.16.2_amd64.deb 72168974 BLAKE2B 2b55f94c9c66b8b19560c4fc95f20d25e44a02862335e9600a0065fa9b068a582560cb067af68a3f7825339485ef2687321d89d6cf0df308f9210561fea99266 SHA512 50cb5e7ef72ee344e09a38015b0eef87e373214202b68fa2db3809d97b1782b5e8d86d7d8adf0d38460a39ad1e1ed1ef9f50c569238af8112ce0fc5c3d28b236
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.16.2.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.16.2.ebuild
new file mode 100644
index 000000000000..e9c70cc55979
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.16.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/gtk+:3[X]
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ net-print/cups
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_prepare(){
+ default
+ sed -e 's|\("/opt/Signal/signal-desktop"\)|\1 --start-in-tray|g' \
+ -i usr/share/applications/signal-desktop.desktop || die
+ unpack usr/share/doc/signal-desktop/changelog.gz
+}
+
+src_install() {
+ insinto /
+ dodoc changelog
+ doins -r opt
+ insinto /usr/share
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}