summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 11:48:11 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commit1489fcc188fcec5458b4de298a0d61734704601a (patch)
treef07e3d552ca728721133f7c8e7138828c37b44b9 /net-im/err
parentnet-mail/mailman: Bump to new python eclasses (diff)
downloadgentoo-1489fcc188fcec5458b4de298a0d61734704601a.tar.gz
gentoo-1489fcc188fcec5458b4de298a0d61734704601a.tar.bz2
gentoo-1489fcc188fcec5458b4de298a0d61734704601a.zip
net-im/err: Move to virtual/dnspython
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-im/err')
-rw-r--r--net-im/err/err-1.7.1-r1.ebuild (renamed from net-im/err/err-1.7.1.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-im/err/err-1.7.1.ebuild b/net-im/err/err-1.7.1-r1.ebuild
index 6e0d11ad0d8d..d48befef4a52 100644
--- a/net-im/err/err-1.7.1.ebuild
+++ b/net-im/err/err-1.7.1-r1.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
+
inherit distutils-r1 eutils user
DESCRIPTION="Plugin based XMPP chatbot designed to be easily deployable, extensible and maintainable"
HOMEPAGE="https://gbin.github.com/err/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
LICENSE="GPL-3"
SLOT="0"
IUSE="irc qt4 +plugins"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/dnspython[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/flask[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyfire[${PYTHON_USEDEP}]
dev-python/python-daemon[${PYTHON_USEDEP}]
dev-python/xmpppy
dev-python/yapsy[${PYTHON_USEDEP}]
+ virtual/dnspython[${PYTHON_USEDEP}]
irc? (
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]