summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 02:23:37 +0100
committerSam James <sam@gentoo.org>2021-08-11 03:05:13 +0100
commit703bca6cb5ee8d54a29c33e37a818f3d6961b29a (patch)
tree024e1895144875ede30f5642010913d9dd0e5be5 /net-im/dino
parentwww-client/firefox-bin: bump to v91.0 (diff)
downloadgentoo-703bca6cb5ee8d54a29c33e37a818f3d6961b29a.tar.gz
gentoo-703bca6cb5ee8d54a29c33e37a818f3d6961b29a.tar.bz2
gentoo-703bca6cb5ee8d54a29c33e37a818f3d6961b29a.zip
net-im/dino: [QA] fix updating icon cache
gnome-utils doesn't supply the cache updating function in newer EAPIs. (Note the "command not found" error in the log within the bug.) Closes: https://bugs.gentoo.org/794856 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/dino-0.2.1.ebuild15
-rw-r--r--net-im/dino/dino-9999.ebuild15
2 files changed, 2 insertions, 28 deletions
diff --git a/net-im/dino/dino-0.2.1.ebuild b/net-im/dino/dino-0.2.1.ebuild
index c640a0cc338e..bdb86b5b3220 100644
--- a/net-im/dino/dino-0.2.1.ebuild
+++ b/net-im/dino/dino-0.2.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
@@ -78,16 +78,3 @@ src_configure() {
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index e0058ccbf6e7..0decbb057e1a 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_MAKEFILE_GENERATOR="ninja"
VALA_MIN_API_VERSION="0.34"
-inherit cmake gnome2-utils vala xdg-utils
+inherit cmake vala xdg
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
@@ -80,16 +80,3 @@ src_configure() {
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}