summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-27 14:40:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-27 14:44:08 +0100
commit9f9849e1f3ef57a397d58117defebbaf4dee134d (patch)
tree79ee0789ffa2ce979887a900ce952716bed57b43 /net-ftp/filezilla
parentnet-ftp/proftpd: arm stable wrt bug #699520 (diff)
downloadgentoo-9f9849e1f3ef57a397d58117defebbaf4dee134d.tar.gz
gentoo-9f9849e1f3ef57a397d58117defebbaf4dee134d.tar.bz2
gentoo-9f9849e1f3ef57a397d58117defebbaf4dee134d.zip
net-ftp/filezilla: Bump to version 3.46.0
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.46.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 84bca8655ac3..252abc302e66 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -3,3 +3,4 @@ DIST FileZilla_3.42.1_src.tar.bz2 4987250 BLAKE2B 8cc6fd0a0cec336f34793520fe4be5
DIST FileZilla_3.43.0_src.tar.bz2 4544635 BLAKE2B 13c99918dd7674fe3f2f0217b39ebe7aa89effe411e3cf90e08c9177278ce143ac84a021e49be0bc0772af29a5c34c33b03ce93d54f0b9918e4ea1001875ea48 SHA512 12c518616508e1cbd7ab60f1b94f8c876c885bc4399674c4b2df34235141fde1297a1edc686078c0f93b040ea6e42984c22ace00c4da201c7f99b4c9b71f5bc1
DIST FileZilla_3.44.2_src.tar.bz2 4619337 BLAKE2B 11d61b14fcf464706dabe491fa8cbfa28fb516c3e1aafd887679ed6f1a80ba835dc43403c32b1344854f00f5b56f7e27c72bbca197cfadc92e69d92ebb0b1458 SHA512 9d4678a3a06f0ecac5ecfbae33f83df5f07e26da4f4a7e922fe5b00a5e59d5728af028667f6fa56210a23ecaa1c2a661d1874b218c2511a783644ed2b03e36ad
DIST FileZilla_3.45.1_src.tar.bz2 4649083 BLAKE2B 8d3113e5ce96d2115a6ec02109f2617d3d58109464c527284baecacea733d2f564206779cd32be4060171d7fcd8768b0296b445842b8c2964b173ca360983082 SHA512 feb267b85ad2843baea0c6df66ed86866121f33e2295fcb9003a8bc2603ad684f4fe801ea842cb291e3fb5cd7195ccb2d21bfa95711a61be6b4debfd4e1c7822
+DIST FileZilla_3.46.0_src.tar.bz2 4661100 BLAKE2B ccda60b590e85afd7de0edd064ee7b993e663e43643f262378db6d26a019730ec493518e0e2b39bce0710acafe888f47f84ecb098e35d3b32061f089a99a6a30 SHA512 26ffb039b4a6d51d6d1011ee452f3690f74514c91a9e58c79880dbf778296cfc81283fade52f65f81654b828449e2b7e703b1d6c1e2e84c08f54681d2aa92674
diff --git a/net-ftp/filezilla/filezilla-3.46.0.ebuild b/net-ftp/filezilla/filezilla-3.46.0.ebuild
new file mode 100644
index 000000000000..b3d583be5cb4
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.46.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.19.1:=
+ <dev-libs/libfilezilla-0.20.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}