summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-22 21:04:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-22 21:04:16 +0100
commit9b160978e3f1007b680209f704b1e479e4770aa0 (patch)
tree2b9b65d970916d6c21c1cf672118c64c25793381 /net-ftp/filezilla
parentdev-libs/libassuan: Bump to version 2.5.5 (diff)
downloadgentoo-9b160978e3f1007b680209f704b1e479e4770aa0.tar.gz
gentoo-9b160978e3f1007b680209f704b1e479e4770aa0.tar.bz2
gentoo-9b160978e3f1007b680209f704b1e479e4770aa0.zip
net-ftp/filezilla: Bump to version 3.53.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.53.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 9ef422372412..e30e4117805f 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.51.0_src.tar.bz2 4808717 BLAKE2B 67f614032145abe7f715254fd47756
DIST FileZilla_3.52.0.5_src.tar.bz2 4811653 BLAKE2B a80d0784e5c85b74cadb944af232bb42fd0170ca31034e51804b56dc06ca2bbc4580a5ed1564bf82436be50be62d86f2017ebf3496ecc00af24837c0da99bbcc SHA512 c0a3f20ad9351ae0bb15e7e488801cdaefc83d5eb1355fcb664150ea588b9fb8c4b446e4b1df5d8b35fb88111a37527037e4dc70ba783d5161b1d91c8dc3bee0
DIST FileZilla_3.52.2_src.tar.bz2 4813167 BLAKE2B af651f4db74e805c866d040aa932c39e1a488bf37b0c215a2cdeae3fd4ab608f84b1b12dfbe8bf197e778760ca26183a3532a370e7a0095c1a250eefdc14717c SHA512 74abb78eaece5ffed044a88bdbbff7be0470e47868b806925ea5666d741370dff910d55849f6ad91fb57f8c1a33c461dc10c9f093d75e7a96ff0d909f3a8f131
DIST FileZilla_3.53.0_src.tar.bz2 4842563 BLAKE2B e9704e5b0c7afee28c3d3efb9b0f72111e9fc4f2d8d69a935d195a09b685f39b80019de77216b5da4353c65837b5b0d8102b3e9e88cad840f3716372232f8bd3 SHA512 b658a0e67d0f92051e5f5503da64f8bc0b1dd6d9af4b54b34d32c9a6c83abe0709b310d940a8f6676f20a49537baca48df805a88c1fa29d7e7b262f59544deff
+DIST FileZilla_3.53.1_src.tar.bz2 4844262 BLAKE2B 1ae9bab7b3812df106340a2267d5634c3e3e3078a5fbb3dcbf526c28ea5bfefe619e380b739533754ec9f4e200d08a398d6ebe0c984a7b18679f0165f3a03e29 SHA512 85109c68c9acaf2d3fb7d2ed98bdeae636cc359993535484ca404bd34e8287927628e255364bdb03681fcc47bff02423e954fd304b2e304bf18efaf2c0784eaa
diff --git a/net-ftp/filezilla/filezilla-3.53.1.ebuild b/net-ftp/filezilla/filezilla-3.53.1.ebuild
new file mode 100644
index 000000000000..c8f67f39ebeb
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.53.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.26.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+ "${FILESDIR}"/${PN}-3.52.2-slibtool.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}