summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-26 09:52:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-26 09:52:57 +0200
commit3863cb68ebf5709d2549ee278180c615f2288bc9 (patch)
tree870f633ab1f60d5c1cdc91a30bdbe88f7565c9c8 /net-fs
parentnet-fs/samba: Bump to version 4.6.9 (diff)
downloadgentoo-3863cb68ebf5709d2549ee278180c615f2288bc9.tar.gz
gentoo-3863cb68ebf5709d2549ee278180c615f2288bc9.tar.bz2
gentoo-3863cb68ebf5709d2549ee278180c615f2288bc9.zip
net-fs/samba: Fixed automagic linking against sys-cluster/ceph
Closes: https://bugs.gentoo.org/563146 Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/metadata.xml1
-rw-r--r--net-fs/samba/samba-4.6.9.ebuild5
-rw-r--r--net-fs/samba/samba-4.7.0-r1.ebuild5
3 files changed, 9 insertions, 2 deletions
diff --git a/net-fs/samba/metadata.xml b/net-fs/samba/metadata.xml
index c6b9bbe87e47..2a3bd677e0d2 100644
--- a/net-fs/samba/metadata.xml
+++ b/net-fs/samba/metadata.xml
@@ -13,6 +13,7 @@
<flag name="addns">Enable AD DNS integration</flag>
<flag name="ads">Enable Active Directory support</flag>
<flag name="aio">Enable asynchronous IO support</flag>
+ <flag name="ceph">Enable support for Ceph distributed filesystem via <pkg>sys-cluster/ceph</pkg></flag>
<flag name="client">Enables the client part</flag>
<flag name="cluster">Enable support for clustering</flag>
<flag name="dmapi">Enable support for DMAPI. This currently works only in combination with XFS.</flag>
diff --git a/net-fs/samba/samba-4.6.9.ebuild b/net-fs/samba/samba-4.6.9.ebuild
index b4690d4142ed..43d075a4a994 100644
--- a/net-fs/samba/samba-4.6.9.ebuild
+++ b/net-fs/samba/samba-4.6.9.ebuild
@@ -24,7 +24,7 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads client cluster cups debug dmapi fam gnutls gpg iprint ldap pam python
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gnutls gpg iprint ldap pam python
quota selinux syslog system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
MULTILIB_WRAPPED_HEADERS=(
@@ -65,6 +65,7 @@ CDEPEND="
net-dns/bind-tools[gssapi]
dev-python/dnspython:=[${PYTHON_USEDEP}]
)
+ ceph? ( sys-cluster/ceph )
cluster? ( !dev-db/ctdb )
cups? ( net-print/cups )
debug? ( dev-util/lttng-ust )
@@ -187,6 +188,7 @@ multilib_src_configure() {
$(usex addc '' '--without-ad-dc')
$(use_with addns dnsupdate)
$(use_with ads)
+ $(use_enable ceph cephfs)
$(use_with cluster cluster-support)
$(use_enable cups)
$(use_with debug lttng)
@@ -215,6 +217,7 @@ multilib_src_configure() {
--without-dnsupdate
--without-ads
--disable-avahi
+ --disable-cephfs
--without-cluster-support
--disable-cups
--without-dmapi
diff --git a/net-fs/samba/samba-4.7.0-r1.ebuild b/net-fs/samba/samba-4.7.0-r1.ebuild
index 382862651762..8e9afc791ab5 100644
--- a/net-fs/samba/samba-4.7.0-r1.ebuild
+++ b/net-fs/samba/samba-4.7.0-r1.ebuild
@@ -23,7 +23,7 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads client cluster cups debug dmapi fam gnutls gpg iprint ldap pam python
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gnutls gpg iprint ldap pam python
quota selinux syslog system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
MULTILIB_WRAPPED_HEADERS=(
@@ -63,6 +63,7 @@ CDEPEND="
net-dns/bind-tools[gssapi]
dev-python/dnspython:=[${PYTHON_USEDEP}]
)
+ ceph? ( sys-cluster/ceph )
cluster? ( !dev-db/ctdb )
cups? ( net-print/cups )
debug? ( dev-util/lttng-ust )
@@ -183,6 +184,7 @@ multilib_src_configure() {
$(usex addc '' '--without-ad-dc')
$(use_with addns dnsupdate)
$(use_with ads)
+ $(use_enable ceph cephfs)
$(use_with cluster cluster-support)
$(use_enable cups)
$(use_with debug lttng)
@@ -211,6 +213,7 @@ multilib_src_configure() {
--without-dnsupdate
--without-ads
--disable-avahi
+ --disable-cephfs
--without-cluster-support
--disable-cups
--without-dmapi