summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-18 10:47:43 +0000
committerSam James <sam@gentoo.org>2024-02-18 10:48:27 +0000
commitcd21eeb283011f6dd23735a67741a2443bdaf641 (patch)
treeef27be9ae26adc83727689f86c6fb6f5b9f163cc /net-dns
parentnet-dns/bind: small tweaks (mostly style, test buffering) (diff)
downloadgentoo-cd21eeb283011f6dd23735a67741a2443bdaf641.tar.gz
gentoo-cd21eeb283011f6dd23735a67741a2443bdaf641.tar.bz2
gentoo-cd21eeb283011f6dd23735a67741a2443bdaf641.zip
net-dns/bind-tools: apply consistency tweaks for net-dns/bind
See b1d4d952897b2c1151e9d8580015f674b21afb0a. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.48.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-dns/bind-tools/bind-tools-9.16.48.ebuild b/net-dns/bind-tools/bind-tools-9.16.48.ebuild
index d33e0ffa5e87..53c0494bb5a5 100644
--- a/net-dns/bind-tools/bind-tools-9.16.48.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.48.ebuild
@@ -13,8 +13,11 @@ MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
HOMEPAGE="https://www.isc.org/software/bind https://gitlab.isc.org/isc-projects/bind9"
-SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz
- verify-sig? ( https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz.asc )"
+SRC_URI="
+ https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz
+ verify-sig? ( https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz.asc )
+"
+S="${WORKDIR}/${MY_P}"
LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
SLOT="0"
@@ -24,9 +27,9 @@ IUSE="+caps doc gssapi idn libedit readline test xml"
RESTRICT="!test? ( test )"
# libuv lower bound should be the highest value seen at
-# https://gitlab.isc.org/isc-projects/bind9/-/blob/v9_16/lib/isc/netmgr/netmgr.c#L244
+# https://gitlab.isc.org/isc-projects/bind9/-/blob/bind-9.16/lib/isc/netmgr/netmgr.c?ref_type=heads#L244
# to avoid issues with matching stable/testing, etc
-COMMON_DEPEND="
+RDEPEND="
>=dev-libs/libuv-1.42.0:=
dev-libs/openssl:=
caps? ( sys-libs/libcap )
@@ -38,9 +41,7 @@ COMMON_DEPEND="
readline? ( sys-libs/readline:= )
)
"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
+DEPEND="${RDEPEND}"
# sphinx required for man-page and html creation
BDEPEND="
virtual/pkgconfig
@@ -52,13 +53,9 @@ BDEPEND="
verify-sig? ( sec-keys/openpgp-keys-isc )
"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
- append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)"
-
# Do not disable thread local storage on Solaris, it works with our
# toolchain, and it breaks further configure checks
sed -i -e '/LDFLAGS=/s/-zrelax=transtls//' configure.ac configure || die
@@ -79,6 +76,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ # localstatedir for nsupdate -l, bug #395785
--localstatedir="${EPREFIX}"/var
--without-python
--without-libjson
@@ -95,7 +93,7 @@ src_configure() {
AR="$(type -P $(tc-getAR))"
)
- # bug 607400
+ # bug #607400
if use libedit ; then
myeconfargs+=( --with-readline=-ledit )
elif use readline ; then
@@ -107,10 +105,11 @@ src_configure() {
# bug #344029
append-cflags "-DDIG_SIGCHASE"
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)"
+
# to expose CMSG_* macros from sys/sockets.h
[[ ${CHOST} == *-solaris* ]] && append-cflags "-D_XOPEN_SOURCE=600"
- # localstatedir for nsupdate -l, bug #395785
tc-export BUILD_CC
econf "${myeconfargs[@]}"
@@ -132,7 +131,7 @@ src_compile() {
src_test() {
# system tests ('emake test') require network configuration for IPs etc
# so we run the unit tests instead.
- TEST_PARALLEL_JOBS="$(makeopts_jobs)" emake unit
+ TEST_PARALLEL_JOBS="$(makeopts_jobs)" emake -Onone unit
}
src_install() {
@@ -158,6 +157,7 @@ src_install() {
fi
cd "${S}"/bin/dnssec || die
+ local tool
for tool in dsfromkey importkey keyfromlabel keygen \
revoke settime signzone verify; do
dobin dnssec-"${tool}"