summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-05-03 12:04:58 +0530
committerZac Medico <zmedico@gentoo.org>2024-05-12 14:07:42 -0700
commit9944f0cbce1bba286093ab452fb0f7d046c0468d (patch)
tree72f9b314b16572c69399ec059e181757d7e9e304 /net-dns
parentnet-dns/coredns: drop 1.11.2 (diff)
downloadgentoo-9944f0cbce1bba286093ab452fb0f7d046c0468d.tar.gz
gentoo-9944f0cbce1bba286093ab452fb0f7d046c0468d.tar.bz2
gentoo-9944f0cbce1bba286093ab452fb0f7d046c0468d.zip
net-dns/coredns: add 1.11.3
* Deps tarball size reduced from 250+ -> 6 MiB * Switch from Makefile build to direct `go build` because former was getting messier with Go versions. Latter is simpler. * Remove test USE flag as not needed anymore Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/36528 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/coredns/Manifest2
-rw-r--r--net-dns/coredns/coredns-1.11.3.ebuild108
-rw-r--r--net-dns/coredns/coredns-9999.ebuild23
3 files changed, 116 insertions, 17 deletions
diff --git a/net-dns/coredns/Manifest b/net-dns/coredns/Manifest
index 7b64f21dc6ff..0deb3578d8d0 100644
--- a/net-dns/coredns/Manifest
+++ b/net-dns/coredns/Manifest
@@ -1,2 +1,4 @@
DIST coredns-1.11.2-r1-deps.tar.xz 6547080 BLAKE2B 19a067a5b402ebe3b8a462e534bbdcf9baade4b5f434c6f24fe8ede0cbe623e2d5d8bdf0ffc06954d796441095688f19caa40f2255a2cc56102fdef36d327ac5 SHA512 caf6e0f1c9be4857059244019d6556f907e4f6907a932c201c856355c3e0b86c1752a90a226d5904c511d0db08ce4869cc5d24203bb4b9e2e1be02e725990332
DIST coredns-1.11.2.tar.gz 651994 BLAKE2B 1a7a272756eaf83170e242a573c8a765d6ea7b70fe422d36a87850b600a88287291aa0fe0d49462c34453d4d3c4d33f9497be409379ff8fccc87f41e2195efc1 SHA512 0e90ef4793555bd46aa5ce84cf639c015d1869b407627c69746eb948abff1920f891c45e5f00c0127f23e2c6394c07cc55c1776af840881210f90faa6ec22b40
+DIST coredns-1.11.3-deps.tar.xz 6662680 BLAKE2B 44bc099586cdaffc381141e347c8921596b0b51bf4f82064d2aca562083597672dfe4b0c965f4c6feebbf4711aff07bd7a301b6ecab28233294978ae94df5fbd SHA512 49690bc11816e1bbc0a5f325abe64648ea820fecd25695f19bf9921f0a38786cddf30e4a385306470a27d17af9d09a5ec50025ff241ea9f3b6b346eddc859755
+DIST coredns-1.11.3.tar.gz 653856 BLAKE2B db9efdd1b674f6908ff094866ca5c148e018d7ddae2ae1cc07c13fbf78dcc4e6ed478d2e5946f73d43b8ee6a1924fecd53759e6b9a41935d084fbb1d84b7bb10 SHA512 3ec9296626a2994d1259329e50b032d2972ef8e05bfed742c0ee570414adbfa8f296046b9356ef73d885a1f1c1e3660421762267535ec2d3f357c3064a75d405
diff --git a/net-dns/coredns/coredns-1.11.3.ebuild b/net-dns/coredns/coredns-1.11.3.ebuild
new file mode 100644
index 000000000000..117795b9f150
--- /dev/null
+++ b/net-dns/coredns/coredns-1.11.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module multiprocessing systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="CoreDNS is a DNS server that chains plugins"
+HOMEPAGE="https://github.com/coredns/coredns"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/coredns/coredns.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+# main
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" MIT BSD ISC MPL-2.0 BSD-2"
+
+SLOT="0"
+# TODO: debug test failure with deps tarball
+RESTRICT="test"
+
+RDEPEND="acct-user/coredns
+ acct-group/coredns"
+
+FILECAPS=(
+ -m 755 'cap_net_bind_service=+ep' usr/bin/${PN}
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ [[ ${PV} != 9999* ]] && { ln -sv ../vendor ./ || die ; }
+ default
+}
+
+src_compile() {
+ [[ ${PV} == 9999* ]] && local GIT_COMMIT="$(git describe --dirty --always)"
+ ego build -ldflags="-s -w -X github.com/coredns/coredns/coremain.GitCommit=${GIT_COMMIT}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+ doman man/*
+
+ newinitd "${FILESDIR}"/coredns.initd coredns
+ newconfd "${FILESDIR}"/coredns.confd coredns
+
+ insinto /etc/coredns/
+ newins "${FILESDIR}"/Corefile.example Corefile
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/coredns.logrotated coredns
+
+ systemd_dounit "${FILESDIR}"/coredns.service
+ newtmpfiles "${FILESDIR}"/coredns.tmpfiles "${PN}.conf"
+}
+
+src_test() {
+ # eclass default '-x' makes tests output unreadable
+ export GOFLAGS="-v -mod=readonly"
+
+ local known_fail=(
+ "TestZoneExternalCNAMELookupWithProxy"
+ "TestMetricsSeveralBlocs"
+ "TestMetricsAvailable"
+ "TestMetricsAvailableAfterReload"
+ "TestMetricsAvailableAfterReloadAndFailedReload"
+ )
+ # concat as '|^Test1$|^Test2$|^Test3...$':
+ local known_fail_re="$(printf '|^%s$' "${known_fail[@]}")"
+ # drop '|' in the begining:
+ known_fail_re="${known_fail_re:1}"
+
+ local working_tests_re="$(
+ # get list of all test:
+ { GOFLAGS="-mod=readonly" go test -list . ./... ||
+ die "Can't get list of tests"; } |
+ # skip "no tests" messages as well as know failures:
+ grep -v -E " |${known_fail_re}" |
+ # format a regexp:
+ sed -z 's/\n/$|^/g'
+ )"
+ # drop '|^' in the end:
+ working_tests_re="^${working_tests_re::-2}"
+
+ go test -race -run "${working_tests_re}" ./... || die "Tests failed"
+ go test -race -run "${known_fail_re}" ./... || ewarn "Known test failure"
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-dns/coredns/coredns-9999.ebuild b/net-dns/coredns/coredns-9999.ebuild
index 52c5778f1173..117795b9f150 100644
--- a/net-dns/coredns/coredns-9999.ebuild
+++ b/net-dns/coredns/coredns-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,6 @@ LICENSE="Apache-2.0"
LICENSE+=" MIT BSD ISC MPL-2.0 BSD-2"
SLOT="0"
-IUSE="test"
# TODO: debug test failure with deps tarball
RESTRICT="test"
@@ -35,32 +34,22 @@ FILECAPS=(
)
src_unpack() {
- if [[ ${PV} == *9999* ]]; then
+ if [[ ${PV} == 9999* ]]; then
git-r3_src_unpack
go-module_live_vendor
else
- go-module_src_unpack
+ default
fi
}
src_prepare() {
+ [[ ${PV} != 9999* ]] && { ln -sv ../vendor ./ || die ; }
default
- use test || sed -i -e 's|coredns: $(CHECKS)|coredns:|' Makefile
}
src_compile() {
- # For non-live versions, prevent git operations which causes sandbox violations
- # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
- [[ ${PV} != 9999* ]] && export GITCOMMIT=''
-
- # Mimicking go-module.eclass's GOFLAGS
- if use amd64 || use arm || use arm64 ||
- ( use ppc64 && [[ $(tc-endian) == "little" ]] ) || use s390 || use x86; then
- local buildmode="-buildmode=pie"
- fi
- export BUILDOPTS="-buildvcs=false -modcacherw -v -x -p=$(makeopts_jobs) ${buildmode}"
-
- default
+ [[ ${PV} == 9999* ]] && local GIT_COMMIT="$(git describe --dirty --always)"
+ ego build -ldflags="-s -w -X github.com/coredns/coredns/coremain.GitCommit=${GIT_COMMIT}"
}
src_install() {